summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.15.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.15.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.15.bb b/meta/recipes-devtools/python/python-native_2.7.15.bb
index 7c491fa3e0..de35104c60 100644
--- a/meta/recipes-devtools/python/python-native_2.7.15.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.15.bb
@@ -69,7 +69,11 @@ python(){
69 import json 69 import json
70 pythondir = d.getVar('THISDIR',True) 70 pythondir = d.getVar('THISDIR',True)
71 with open(pythondir+'/python/python2-manifest.json') as manifest_file: 71 with open(pythondir+'/python/python2-manifest.json') as manifest_file:
72 python_manifest=json.load(manifest_file) 72 manifest_str = manifest_file.read()
73 json_start = manifest_str.find('# EOC') + 6
74 manifest_file.seek(json_start)
75 manifest_str = manifest_file.read()
76 python_manifest = json.loads(manifest_str)
73 77
74 rprovides = d.getVar('RPROVIDES').split() 78 rprovides = d.getVar('RPROVIDES').split()
75 79