summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.12.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.12.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.12.bb b/meta/recipes-devtools/python/python-native_2.7.12.bb
new file mode 100644
index 0000000000..de83cbd76a
--- /dev/null
+++ b/meta/recipes-devtools/python/python-native_2.7.12.bb
@@ -0,0 +1,61 @@
1require python.inc
2
3EXTRANATIVEPATH += "bzip2-native"
4DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native expat-native"
5PR = "${INC_PR}.1"
6
7SRC_URI += "\
8 file://05-enable-ctypes-cross-build.patch \
9 file://10-distutils-fix-swig-parameter.patch \
10 file://11-distutils-never-modify-shebang-line.patch \
11 file://0001-distutils-set-the-prefix-to-be-inside-staging-direct.patch \
12 file://debug.patch \
13 file://unixccompiler.patch \
14 file://nohostlibs.patch \
15 file://multilib.patch \
16 file://add-md5module-support.patch \
17 file://builddir.patch \
18 file://parallel-makeinst-create-bindir.patch \
19 file://revert_use_of_sysconfigdata.patch \
20 "
21
22S = "${WORKDIR}/Python-${PV}"
23
24FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:"
25
26inherit native
27
28RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-codecs-native python-core-native python-unittest-native"
29
30EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --with-system-expat=${STAGING_DIR_HOST}"
31
32EXTRA_OEMAKE = '\
33 LIBC="" \
34 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
35 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
36'
37
38do_configure_append() {
39 autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
40}
41
42do_install() {
43 oe_runmake 'DESTDIR=${D}' install
44 install -d ${D}${bindir}/${PN}
45 install -m 0755 Parser/pgen ${D}${bindir}/${PN}
46
47 # Make sure we use /usr/bin/env python
48 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
49 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
50 done
51
52 # Add a symlink to the native Python so that scripts can just invoke
53 # "nativepython" and get the right one without needing absolute paths
54 # (these often end up too long for the #! parser in the kernel as the
55 # buffer is 128 bytes long).
56 ln -s python-native/python ${D}${bindir}/nativepython
57
58 # We don't want modules in ~/.local being used in preference to those
59 # installed in the native sysroot, so disable user site support.
60 sed -i -e 's,^\(ENABLE_USER_SITE = \).*,\1False,' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py
61}