summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.12.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.12.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.12.bb b/meta/recipes-devtools/python/python-native_2.7.12.bb
new file mode 100644
index 0000000000..d41c69e19e
--- /dev/null
+++ b/meta/recipes-devtools/python/python-native_2.7.12.bb
@@ -0,0 +1,62 @@
1require python.inc
2
3EXTRANATIVEPATH += "bzip2-native"
4DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native"
5PR = "${INC_PR}.1"
6
7SRC_URI += "\
8 file://05-enable-ctypes-cross-build.patch \
9 file://10-distutils-fix-swig-parameter.patch \
10 file://11-distutils-never-modify-shebang-line.patch \
11 file://12-distutils-prefix-is-inside-staging-area.patch \
12 file://debug.patch \
13 file://unixccompiler.patch \
14 file://nohostlibs.patch \
15 file://multilib.patch \
16 file://add-md5module-support.patch \
17 file://builddir.patch \
18 file://parallel-makeinst-create-bindir.patch \
19 file://revert_use_of_sysconfigdata.patch \
20 "
21S = "${WORKDIR}/Python-${PV}"
22
23FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:"
24
25inherit native
26
27RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-codecs-native python-core-native python-unittest-native"
28
29EXTRA_OECONF_append = " --bindir=${bindir}/${PN}"
30
31EXTRA_OEMAKE = '\
32 BUILD_SYS="" \
33 HOST_SYS="" \
34 LIBC="" \
35 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
36 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
37'
38
39do_configure_append() {
40 autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
41}
42
43do_install() {
44 oe_runmake 'DESTDIR=${D}' install
45 install -d ${D}${bindir}/${PN}
46 install -m 0755 Parser/pgen ${D}${bindir}/${PN}
47
48 # Make sure we use /usr/bin/env python
49 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
50 sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT
51 done
52
53 # Add a symlink to the native Python so that scripts can just invoke
54 # "nativepython" and get the right one without needing absolute paths
55 # (these often end up too long for the #! parser in the kernel as the
56 # buffer is 128 bytes long).
57 ln -s python-native/python ${D}${bindir}/nativepython
58
59 # We don't want modules in ~/.local being used in preference to those
60 # installed in the native sysroot, so disable user site support.
61 sed -i -e 's,^\(ENABLE_USER_SITE = \).*,\1False,' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py
62}