summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.6.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.6.5.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.6.5.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.6.5.bb b/meta/recipes-devtools/python/python-native_2.6.5.bb
new file mode 100644
index 0000000000..cb95e4b964
--- /dev/null
+++ b/meta/recipes-devtools/python/python-native_2.6.5.bb
@@ -0,0 +1,30 @@
1require python.inc
2DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
3PR = "${INC_PR}.3"
4
5SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
6 file://00-fix-bindir-libdir-for-cross.patch \
7 file://04-default-is-optimized.patch \
8 file://05-enable-ctypes-cross-build.patch \
9 file://10-distutils-fix-swig-parameter.patch \
10 file://11-distutils-never-modify-shebang-line.patch \
11 file://12-distutils-prefix-is-inside-staging-area.patch \
12 file://debug.patch \
13 file://nohostlibs.patch"
14S = "${WORKDIR}/Python-${PV}"
15
16inherit native
17
18EXTRA_OEMAKE = '\
19 BUILD_SYS="" \
20 HOST_SYS="" \
21 LIBC="" \
22 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
23 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
24'
25
26do_install() {
27 oe_runmake 'DESTDIR=${D}' install
28 install -d ${D}${bindir}/
29 install -m 0755 Parser/pgen ${D}${bindir}/
30}