summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-imaging_1.1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-imaging_1.1.7.bb')
-rw-r--r--meta/recipes-devtools/python/python-imaging_1.1.7.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-imaging_1.1.7.bb b/meta/recipes-devtools/python/python-imaging_1.1.7.bb
new file mode 100644
index 0000000000..98120432ac
--- /dev/null
+++ b/meta/recipes-devtools/python/python-imaging_1.1.7.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "Python Imaging Library"
2SECTION = "devel/python"
3PRIORITY = "optional"
4LICENSE = "GPL"
5DEPENDS = "freetype jpeg tiff"
6RDEPENDS = "python-lang python-stringold"
7SRCNAME = "Imaging"
8PR = "ml0"
9
10SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
11 file://path.patch"
12S = "${WORKDIR}/${SRCNAME}-${PV}"
13
14inherit distutils
15
16do_compile() {
17 export STAGING_LIBDIR=${STAGING_LIBDIR}
18 export STAGING_INCDIR=${STAGING_INCDIR}
19 distutils_do_compile
20}
21
22do_install() {
23 export STAGING_LIBDIR=${STAGING_LIBDIR}
24 export STAGING_INCDIR=${STAGING_INCDIR}
25 distutils_do_install
26 install -d ${D}${datadir}/doc/${PN}/html/
27 install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
28 install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
29
30}