summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-gst_0.10.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-gst_0.10.22.bb')
-rw-r--r--meta/recipes-devtools/python/python-gst_0.10.22.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-gst_0.10.22.bb b/meta/recipes-devtools/python/python-gst_0.10.22.bb
new file mode 100644
index 0000000000..2a5f2b3239
--- /dev/null
+++ b/meta/recipes-devtools/python/python-gst_0.10.22.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Python bindings for the GStreamer multimedia framework"
2SECTION = "devel/python"
3LICENSE = "LGPLv2.1"
4DEPENDS = "gstreamer gst-plugins-base python-pygobject"
5RDEPENDS_${PN} += "python-pygtk"
6PR = "r2"
7
8SRC_URI = "http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
9 file://python-path.patch"
10
11SRC_URI[md5sum] = "937152fe896241f827689f4b53e79b22"
12SRC_URI[sha256sum] = "8f26f519a5bccd770864317e098e5e307fc5ad1201eb96329634b6508b253178"
13S = "${WORKDIR}/gst-python-${PV}"
14
15LIC_FILES_CHKSUM = "file://COPYING;md5=39ff67e932b7bdfa9b78bad67151690b"
16
17inherit autotools distutils-base pkgconfig
18
19EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
20
21FILES_${PN} += "${datadir}/gst-python"
22FILES_${PN}-dev += "${datadir}/gst-python/0.10/defs"
23FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/gst-0.10/gst/.debug/ ${libdir}/gstreamer-0.10/.debug/"
24
25do_configure_prepend() {
26 if [ `find ${STAGING_LIBDIR} -name libpython*.so` ]; then
27 ln -sf ${STAGING_LIBDIR}/libpython*.so `find ${STAGING_LIBDIR} -name libpython*.a -exec dirname {} \;`
28 fi
29}