summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-git_0.3.2.RC1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python/python-git_0.3.2.RC1.bb')
-rw-r--r--meta/recipes-devtools/python/python-git_0.3.2.RC1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-git_0.3.2.RC1.bb b/meta/recipes-devtools/python/python-git_0.3.2.RC1.bb
new file mode 100644
index 0000000000..02a0eac040
--- /dev/null
+++ b/meta/recipes-devtools/python/python-git_0.3.2.RC1.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10DEPENDS = "python-gitdb"
11
12SRC_URI = "http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
13SRC_URI[md5sum] = "849082fe29adc653a3621465213cab96"
14SRC_URI[sha256sum] = "fd6786684a0d0dd7ebb961da754e3312fafe0c8e88f55ceb09858aa0af6094e0"
15
16S = "${WORKDIR}/GitPython-${PV}"
17
18inherit setuptools
19
20RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold"
21
22BBCLASSEXTEND = "nativesdk"