summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/python3-numpy_1.19.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python-numpy/python3-numpy_1.19.5.bb')
-rw-r--r--meta/recipes-devtools/python-numpy/python3-numpy_1.19.5.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.19.5.bb b/meta/recipes-devtools/python-numpy/python3-numpy_1.19.5.bb
new file mode 100644
index 0000000000..5037d2a422
--- /dev/null
+++ b/meta/recipes-devtools/python-numpy/python3-numpy_1.19.5.bb
@@ -0,0 +1,58 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD & MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e527e2a94c4584cd192d03ffb1f4a744"
5
6SRCNAME = "numpy"
7
8SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
9 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
10 file://0001-numpy-core-Define-RISCV-32-support.patch \
11 file://run-ptest \
12"
13SRC_URI[sha256sum] = "d1654047d75fb9d55cc3d46f312d5247eec5f4999039874d2f571bb8021d8f0b"
14
15UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
16UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
17
18DEPENDS += "python3-cython-native"
19
20inherit ptest setuptools3
21
22S = "${WORKDIR}/numpy-${PV}"
23
24CLEANBROKEN = "1"
25
26FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
27
28# install what is needed for numpy.test()
29RDEPENDS_${PN} = "${PYTHON_PN}-unittest \
30 ${PYTHON_PN}-difflib \
31 ${PYTHON_PN}-pprint \
32 ${PYTHON_PN}-pickle \
33 ${PYTHON_PN}-shell \
34 ${PYTHON_PN}-doctest \
35 ${PYTHON_PN}-datetime \
36 ${PYTHON_PN}-distutils \
37 ${PYTHON_PN}-misc \
38 ${PYTHON_PN}-mmap \
39 ${PYTHON_PN}-netclient \
40 ${PYTHON_PN}-numbers \
41 ${PYTHON_PN}-pydoc \
42 ${PYTHON_PN}-pkgutil \
43 ${PYTHON_PN}-email \
44 ${PYTHON_PN}-compression \
45 ${PYTHON_PN}-ctypes \
46 ${PYTHON_PN}-threading \
47 ${PYTHON_PN}-multiprocessing \
48"
49RDEPENDS_${PN}-ptest += "${PYTHON_PN}-pytest \
50 ${PYTHON_PN}-hypothesis \
51 ${PYTHON_PN}-sortedcontainers \
52 ${PYTHON_PN}-resource \
53 ldd \
54"
55
56RDEPENDS_${PN}_class-native = ""
57
58BBCLASSEXTEND = "native nativesdk"