summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/python3-numpy_1.19.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python-numpy/python3-numpy_1.19.4.bb')
-rw-r--r--meta/recipes-devtools/python-numpy/python3-numpy_1.19.4.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.19.4.bb b/meta/recipes-devtools/python-numpy/python3-numpy_1.19.4.bb
new file mode 100644
index 0000000000..d54f2f6c18
--- /dev/null
+++ b/meta/recipes-devtools/python-numpy/python3-numpy_1.19.4.bb
@@ -0,0 +1,52 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD & MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e527e2a94c4584cd192d03ffb1f4a744"
5
6SRCNAME = "numpy"
7
8SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
9 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
10 file://0001-numpy-core-Define-RISCV-32-support.patch \
11"
12SRC_URI[sha256sum] = "fe836a685d6838dbb3f603caef01183ea98e88febf4ce956a2ea484a75378413"
13
14UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
15UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
16
17DEPENDS += "python3-cython-native"
18
19inherit setuptools3
20
21S = "${WORKDIR}/numpy-${PV}"
22
23CLEANBROKEN = "1"
24
25FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
26
27# install what is needed for numpy.test()
28RDEPENDS_${PN} = "${PYTHON_PN}-unittest \
29 ${PYTHON_PN}-difflib \
30 ${PYTHON_PN}-pprint \
31 ${PYTHON_PN}-pickle \
32 ${PYTHON_PN}-shell \
33 ${PYTHON_PN}-nose \
34 ${PYTHON_PN}-doctest \
35 ${PYTHON_PN}-datetime \
36 ${PYTHON_PN}-distutils \
37 ${PYTHON_PN}-misc \
38 ${PYTHON_PN}-mmap \
39 ${PYTHON_PN}-netclient \
40 ${PYTHON_PN}-numbers \
41 ${PYTHON_PN}-pydoc \
42 ${PYTHON_PN}-pkgutil \
43 ${PYTHON_PN}-email \
44 ${PYTHON_PN}-compression \
45 ${PYTHON_PN}-ctypes \
46 ${PYTHON_PN}-threading \
47 ${PYTHON_PN}-multiprocessing \
48"
49
50RDEPENDS_${PN}_class-native = ""
51
52BBCLASSEXTEND = "native nativesdk"