diff options
Diffstat (limited to 'meta/recipes-devtools/python-numpy/python-numpy_1.14.1.bb')
-rw-r--r-- | meta/recipes-devtools/python-numpy/python-numpy_1.14.1.bb | 113 |
1 files changed, 113 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/python-numpy_1.14.1.bb b/meta/recipes-devtools/python-numpy/python-numpy_1.14.1.bb new file mode 100644 index 0000000000..6b5dd67fa3 --- /dev/null +++ b/meta/recipes-devtools/python-numpy/python-numpy_1.14.1.bb | |||
@@ -0,0 +1,113 @@ | |||
1 | SUMMARY = "A sophisticated Numeric Processing Package for Python" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & BSD" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fc53b33304171d132128ebe82ea4a645" | ||
5 | |||
6 | SRCNAME = "numpy" | ||
7 | |||
8 | SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \ | ||
9 | file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ | ||
10 | file://fix_shebang_f2py.patch \ | ||
11 | ${CONFIGFILESURI} " | ||
12 | |||
13 | SRC_URI[md5sum] = "0e09f20f62ab9f8a02cb7bd3fd023482" | ||
14 | SRC_URI[sha256sum] = "8708a775be9a9a457b80a49193c57bd9d51a8a195ed1f1c4b8e89eaf3aa646ee" | ||
15 | |||
16 | UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases" | ||
17 | UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar" | ||
18 | |||
19 | CONFIGFILESURI ?= "" | ||
20 | |||
21 | CONFIGFILESURI_aarch64 = " \ | ||
22 | file://config.h \ | ||
23 | file://_numpyconfig.h \ | ||
24 | " | ||
25 | CONFIGFILESURI_arm = " \ | ||
26 | file://config.h \ | ||
27 | file://numpyconfig.h \ | ||
28 | " | ||
29 | CONFIGFILESURI_armeb = " \ | ||
30 | file://config.h \ | ||
31 | file://numpyconfig.h \ | ||
32 | " | ||
33 | CONFIGFILESURI_mipsarcho32el = " \ | ||
34 | file://config.h \ | ||
35 | file://numpyconfig.h \ | ||
36 | " | ||
37 | CONFIGFILESURI_x86 = " \ | ||
38 | file://config.h \ | ||
39 | file://numpyconfig.h \ | ||
40 | " | ||
41 | CONFIGFILESURI_x86-64 = " \ | ||
42 | file://config.h \ | ||
43 | file://_numpyconfig.h \ | ||
44 | " | ||
45 | CONFIGFILESURI_mipsarcho32eb = " \ | ||
46 | file://config.h \ | ||
47 | file://_numpyconfig.h \ | ||
48 | " | ||
49 | CONFIGFILESURI_powerpc = " \ | ||
50 | file://config.h \ | ||
51 | file://_numpyconfig.h \ | ||
52 | " | ||
53 | CONFIGFILESURI_powerpc64 = " \ | ||
54 | file://config.h \ | ||
55 | file://_numpyconfig.h \ | ||
56 | " | ||
57 | CONFIGFILESURI_mipsarchn64eb = " \ | ||
58 | file://config.h \ | ||
59 | file://_numpyconfig.h \ | ||
60 | " | ||
61 | CONFIGFILESURI_mipsarchn64el = " \ | ||
62 | file://config.h \ | ||
63 | file://_numpyconfig.h \ | ||
64 | " | ||
65 | CONFIGFILESURI_mipsarchn32eb = " \ | ||
66 | file://config.h \ | ||
67 | file://_numpyconfig.h \ | ||
68 | " | ||
69 | CONFIGFILESURI_mipsarchn32el = " \ | ||
70 | file://config.h \ | ||
71 | file://_numpyconfig.h \ | ||
72 | " | ||
73 | |||
74 | S = "${WORKDIR}/numpy-${PV}" | ||
75 | |||
76 | inherit setuptools | ||
77 | |||
78 | # Make the build fail and replace *config.h with proper one | ||
79 | # This is a ugly, ugly hack - Koen | ||
80 | do_compile_prepend_class-target() { | ||
81 | ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ | ||
82 | true | ||
83 | cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/ | ||
84 | } | ||
85 | |||
86 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a" | ||
87 | |||
88 | # install what is needed for numpy.test() | ||
89 | RDEPENDS_${PN} = "python-unittest \ | ||
90 | python-difflib \ | ||
91 | python-pprint \ | ||
92 | python-pickle \ | ||
93 | python-shell \ | ||
94 | python-nose \ | ||
95 | python-doctest \ | ||
96 | python-datetime \ | ||
97 | python-distutils \ | ||
98 | python-misc \ | ||
99 | python-mmap \ | ||
100 | python-netclient \ | ||
101 | python-numbers \ | ||
102 | python-pydoc \ | ||
103 | python-pkgutil \ | ||
104 | python-email \ | ||
105 | python-subprocess \ | ||
106 | python-compression \ | ||
107 | python-ctypes \ | ||
108 | python-threading \ | ||
109 | " | ||
110 | |||
111 | RDEPENDS_${PN}_class-native = "" | ||
112 | |||
113 | BBCLASSEXTEND = "native nativesdk" | ||