diff options
Diffstat (limited to 'meta/recipes-devtools/python-numpy/python-numpy_1.11.1.bb')
-rw-r--r-- | meta/recipes-devtools/python-numpy/python-numpy_1.11.1.bb | 104 |
1 files changed, 104 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/python-numpy_1.11.1.bb b/meta/recipes-devtools/python-numpy/python-numpy_1.11.1.bb new file mode 100644 index 0000000000..c5af720a9c --- /dev/null +++ b/meta/recipes-devtools/python-numpy/python-numpy_1.11.1.bb | |||
@@ -0,0 +1,104 @@ | |||
1 | SUMMARY = "A sophisticated Numeric Processing Package for Python" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7e51a5677b22b865abbfb3dff6ffb2d0" | ||
5 | |||
6 | SRCNAME = "numpy" | ||
7 | |||
8 | SRC_URI = "https://files.pythonhosted.org/packages/source/n/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ | ||
9 | file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ | ||
10 | file://remove-build-path-in-comments.patch \ | ||
11 | file://fix_shebang_f2py.patch \ | ||
12 | ${CONFIGFILESURI} " | ||
13 | UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/numpy/files/" | ||
14 | |||
15 | CONFIGFILESURI ?= "" | ||
16 | |||
17 | CONFIGFILESURI_aarch64 = " \ | ||
18 | file://config.h \ | ||
19 | file://_numpyconfig.h \ | ||
20 | " | ||
21 | CONFIGFILESURI_arm = " \ | ||
22 | file://config.h \ | ||
23 | file://numpyconfig.h \ | ||
24 | " | ||
25 | CONFIGFILESURI_armeb = " \ | ||
26 | file://config.h \ | ||
27 | file://numpyconfig.h \ | ||
28 | " | ||
29 | CONFIGFILESURI_mipsel = " \ | ||
30 | file://config.h \ | ||
31 | file://numpyconfig.h \ | ||
32 | " | ||
33 | CONFIGFILESURI_x86 = " \ | ||
34 | file://config.h \ | ||
35 | file://numpyconfig.h \ | ||
36 | " | ||
37 | CONFIGFILESURI_x86-64 = " \ | ||
38 | file://config.h \ | ||
39 | file://_numpyconfig.h \ | ||
40 | " | ||
41 | CONFIGFILESURI_mips = " \ | ||
42 | file://config.h \ | ||
43 | file://_numpyconfig.h \ | ||
44 | " | ||
45 | CONFIGFILESURI_powerpc = " \ | ||
46 | file://config.h \ | ||
47 | file://_numpyconfig.h \ | ||
48 | " | ||
49 | CONFIGFILESURI_powerpc64 = " \ | ||
50 | file://config.h \ | ||
51 | file://_numpyconfig.h \ | ||
52 | " | ||
53 | CONFIGFILESURI_mips64 = " \ | ||
54 | file://config.h \ | ||
55 | file://_numpyconfig.h \ | ||
56 | " | ||
57 | CONFIGFILESURI_mips64n32 = " \ | ||
58 | file://config.h \ | ||
59 | file://_numpyconfig.h \ | ||
60 | " | ||
61 | |||
62 | S = "${WORKDIR}/numpy-${PV}" | ||
63 | |||
64 | inherit setuptools | ||
65 | |||
66 | # Make the build fail and replace *config.h with proper one | ||
67 | # This is a ugly, ugly hack - Koen | ||
68 | do_compile_prepend_class-target() { | ||
69 | ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ | ||
70 | true | ||
71 | cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/ | ||
72 | } | ||
73 | |||
74 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a" | ||
75 | |||
76 | SRC_URI[md5sum] = "2f44a895a8104ffac140c3a70edbd450" | ||
77 | SRC_URI[sha256sum] = "dc4082c43979cc856a2bf352a8297ea109ccb3244d783ae067eb2ee5b0d577cd" | ||
78 | |||
79 | # install what is needed for numpy.test() | ||
80 | RDEPENDS_${PN} = "python-unittest \ | ||
81 | python-difflib \ | ||
82 | python-pprint \ | ||
83 | python-pickle \ | ||
84 | python-shell \ | ||
85 | python-nose \ | ||
86 | python-doctest \ | ||
87 | python-datetime \ | ||
88 | python-distutils \ | ||
89 | python-misc \ | ||
90 | python-mmap \ | ||
91 | python-netclient \ | ||
92 | python-numbers \ | ||
93 | python-pydoc \ | ||
94 | python-pkgutil \ | ||
95 | python-email \ | ||
96 | python-subprocess \ | ||
97 | python-compression \ | ||
98 | python-ctypes \ | ||
99 | python-threading \ | ||
100 | " | ||
101 | |||
102 | RDEPENDS_${PN}_class-native = "" | ||
103 | |||
104 | BBCLASSEXTEND = "native nativesdk" | ||