summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/python-numpy_1.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python-numpy/python-numpy_1.11.0.bb')
-rw-r--r--meta/recipes-devtools/python-numpy/python-numpy_1.11.0.bb103
1 files changed, 103 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/python-numpy_1.11.0.bb b/meta/recipes-devtools/python-numpy/python-numpy_1.11.0.bb
new file mode 100644
index 0000000000..51ef171052
--- /dev/null
+++ b/meta/recipes-devtools/python-numpy/python-numpy_1.11.0.bb
@@ -0,0 +1,103 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7e51a5677b22b865abbfb3dff6ffb2d0"
5
6SRCNAME = "numpy"
7
8SRC_URI = "https://files.pythonhosted.org/packages/source/n/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
9 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
10 file://remove-build-path-in-comments.patch \
11 file://fix_shebang_f2py.patch \
12 ${CONFIGFILESURI} "
13
14CONFIGFILESURI ?= ""
15
16CONFIGFILESURI_aarch64 = " \
17 file://config.h \
18 file://_numpyconfig.h \
19"
20CONFIGFILESURI_arm = " \
21 file://config.h \
22 file://numpyconfig.h \
23"
24CONFIGFILESURI_armeb = " \
25 file://config.h \
26 file://numpyconfig.h \
27"
28CONFIGFILESURI_mipsel = " \
29 file://config.h \
30 file://numpyconfig.h \
31"
32CONFIGFILESURI_x86 = " \
33 file://config.h \
34 file://numpyconfig.h \
35"
36CONFIGFILESURI_x86-64 = " \
37 file://config.h \
38 file://_numpyconfig.h \
39"
40CONFIGFILESURI_mips = " \
41 file://config.h \
42 file://_numpyconfig.h \
43"
44CONFIGFILESURI_powerpc = " \
45 file://config.h \
46 file://_numpyconfig.h \
47"
48CONFIGFILESURI_powerpc64 = " \
49 file://config.h \
50 file://_numpyconfig.h \
51"
52CONFIGFILESURI_mips64 = " \
53 file://config.h \
54 file://_numpyconfig.h \
55"
56CONFIGFILESURI_mips64n32 = " \
57 file://config.h \
58 file://_numpyconfig.h \
59"
60
61S = "${WORKDIR}/numpy-${PV}"
62
63inherit setuptools
64
65# Make the build fail and replace *config.h with proper one
66# This is a ugly, ugly hack - Koen
67do_compile_prepend_class-target() {
68 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
69 true
70 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
71}
72
73FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
74
75SRC_URI[md5sum] = "bc56fb9fc2895aa4961802ffbdb31d0b"
76SRC_URI[sha256sum] = "a1d1268d200816bfb9727a7a27b78d8e37ecec2e4d5ebd33eb64e2789e0db43e"
77
78# install what is needed for numpy.test()
79RDEPENDS_${PN} = "python-unittest \
80 python-difflib \
81 python-pprint \
82 python-pickle \
83 python-shell \
84 python-nose \
85 python-doctest \
86 python-datetime \
87 python-distutils \
88 python-misc \
89 python-mmap \
90 python-netclient \
91 python-numbers \
92 python-pydoc \
93 python-pkgutil \
94 python-email \
95 python-subprocess \
96 python-compression \
97 python-ctypes \
98 python-threading \
99"
100
101RDEPENDS_${PN}_class-native = ""
102
103BBCLASSEXTEND = "native nativesdk"