summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb')
-rw-r--r--meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb b/meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb
new file mode 100644
index 0000000000..6d3b8d569d
--- /dev/null
+++ b/meta/recipes-devtools/python-backports-lzma/python-backports-lzma_git.bb
@@ -0,0 +1,21 @@
1HOMEPAGE = "https://github.com/peterjc/backports.lzma"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=846e05e7e9e1c886b2637c230cfcd5dd"
4
5SRC_URI = "git://github.com/peterjc/backports.lzma.git \
6 file://0001-setup.py-do-not-add-include-and-library-directories-.patch \
7 "
8
9PV = "0.0.6+git${SRCPV}"
10SRCREV = "718b3316ae7aee8e03c02e7e110108779ce3aec8"
11
12S = "${WORKDIR}/git"
13
14inherit distutils
15
16DEPENDS_append = " xz"
17
18RDEPENDS_${PN} += "python-core python-io python-pkgutil"
19RDEPENDS_${PN}_class-native += "python-core"
20
21BBCLASSEXTEND = "native"