diff options
Diffstat (limited to 'meta/recipes-devtools/pseudo/pseudo_git.bb')
-rw-r--r-- | meta/recipes-devtools/pseudo/pseudo_git.bb | 38 |
1 files changed, 33 insertions, 5 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb index 4e94df7e8c..244fabe1eb 100644 --- a/meta/recipes-devtools/pseudo/pseudo_git.bb +++ b/meta/recipes-devtools/pseudo/pseudo_git.bb | |||
@@ -6,7 +6,7 @@ LICENSE = "LGPL2.1" | |||
6 | DEPENDS = "sqlite3" | 6 | DEPENDS = "sqlite3" |
7 | 7 | ||
8 | PV = "0.0+git${SRCPV}" | 8 | PV = "0.0+git${SRCPV}" |
9 | PR = "r17" | 9 | PR = "r18" |
10 | 10 | ||
11 | SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \ | 11 | SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \ |
12 | file://static_sqlite.patch \ | 12 | file://static_sqlite.patch \ |
@@ -25,7 +25,26 @@ do_configure () { | |||
25 | 25 | ||
26 | NO32LIBS ??= "0" | 26 | NO32LIBS ??= "0" |
27 | 27 | ||
28 | # Compile for the local machine arch... | ||
28 | do_compile () { | 29 | do_compile () { |
30 | ${S}/configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=${SITEINFO_BITS} | ||
31 | oe_runmake 'LIB=lib/pseudo/lib$(MARK64)' | ||
32 | } | ||
33 | |||
34 | # Two below are the same | ||
35 | # If necessary compile for the alternative machine arch. This is only | ||
36 | # necessary in a native build. | ||
37 | do_compile_prepend_virtclass-native () { | ||
38 | if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then | ||
39 | # We need the 32-bit libpseudo on a 64-bit machine... | ||
40 | ./configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=32 | ||
41 | oe_runmake 'CFLAGS=-m32' 'LIB=lib/pseudo/lib' libpseudo | ||
42 | # prevent it from removing the lib, but remove everything else | ||
43 | make 'LIB=foo' distclean | ||
44 | fi | ||
45 | } | ||
46 | |||
47 | do_compile_prepend_virtclass-nativesdk () { | ||
29 | if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then | 48 | if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then |
30 | # We need the 32-bit libpseudo on a 64-bit machine... | 49 | # We need the 32-bit libpseudo on a 64-bit machine... |
31 | ./configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=32 | 50 | ./configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=32 |
@@ -33,18 +52,27 @@ do_compile () { | |||
33 | # prevent it from removing the lib, but remove everything else | 52 | # prevent it from removing the lib, but remove everything else |
34 | make 'LIB=foo' distclean | 53 | make 'LIB=foo' distclean |
35 | fi | 54 | fi |
36 | ${S}/configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=${SITEINFO_BITS} | ||
37 | oe_runmake 'LIB=lib/pseudo/lib$(MARK64)' | ||
38 | } | 55 | } |
39 | 56 | ||
40 | do_install () { | 57 | do_install () { |
41 | oe_runmake 'DESTDIR=${D}' 'LIB=lib/pseudo/lib$(MARK64)' install | 58 | oe_runmake 'DESTDIR=${D}' 'LIB=lib/pseudo/lib$(MARK64)' install |
59 | } | ||
60 | |||
61 | # Two below are the same | ||
62 | # If necessary install for the alternative machine arch. This is only | ||
63 | # necessary in a native build. | ||
64 | do_install_append_virtclass-native () { | ||
42 | if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then | 65 | if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then |
43 | mkdir -p ${D}${prefix}/lib/pseudo/lib | 66 | mkdir -p ${D}${prefix}/lib/pseudo/lib |
44 | cp lib/pseudo/lib/libpseudo.so ${D}${prefix}/lib/pseudo/lib/. | 67 | cp lib/pseudo/lib/libpseudo.so ${D}${prefix}/lib/pseudo/lib/. |
45 | fi | 68 | fi |
46 | } | 69 | } |
47 | 70 | ||
48 | BBCLASSEXTEND = "native nativesdk" | 71 | do_install_append_virtclass-nativesdk () { |
49 | 72 | if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" -a "${NO32LIBS}" != "1" ]; then | |
73 | mkdir -p ${D}${prefix}/lib/pseudo/lib | ||
74 | cp lib/pseudo/lib/libpseudo.so ${D}${prefix}/lib/pseudo/lib/. | ||
75 | fi | ||
76 | } | ||
50 | 77 | ||
78 | BBCLASSEXTEND = "native nativesdk" | ||