diff options
Diffstat (limited to 'meta/recipes-devtools/pseudo/pseudo_git.bb')
-rw-r--r-- | meta/recipes-devtools/pseudo/pseudo_git.bb | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb new file mode 100644 index 0000000000..4cb483ea60 --- /dev/null +++ b/meta/recipes-devtools/pseudo/pseudo_git.bb | |||
@@ -0,0 +1,47 @@ | |||
1 | DESCRIPTION = "Pseudo gives fake root capabilities to a normal user" | ||
2 | HOMEPAGE = "http://wiki.github.com/wrpseudo/pseudo/" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad" | ||
4 | SECTION = "base" | ||
5 | LICENSE = "LGPL2.1" | ||
6 | DEPENDS = "sqlite3" | ||
7 | |||
8 | PV = "0.0+git${SRCPV}" | ||
9 | PR = "r14" | ||
10 | |||
11 | SRC_URI = "git://github.com/wrpseudo/pseudo.git;protocol=git \ | ||
12 | file://static_sqlite.patch" | ||
13 | |||
14 | FILES_${PN} = "${libdir}/libpseudo.so ${bindir}/* ${localstatedir}/pseudo" | ||
15 | PROVIDES += "virtual/fakeroot" | ||
16 | |||
17 | S = "${WORKDIR}/git" | ||
18 | |||
19 | inherit siteinfo | ||
20 | |||
21 | do_configure () { | ||
22 | : | ||
23 | } | ||
24 | |||
25 | do_compile () { | ||
26 | if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" ]; then | ||
27 | # We need the 32-bit libpseudo on a 64-bit machine... | ||
28 | ./configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=32 | ||
29 | oe_runmake 'CFLAGS=-m32' 'LIB=lib/pseudo/lib' libpseudo | ||
30 | # prevent it from removing the lib, but remove everything else | ||
31 | make 'LIB=foo' distclean | ||
32 | fi | ||
33 | ${S}/configure --prefix=${prefix} --with-sqlite=${STAGING_DIR_TARGET}${exec_prefix} --bits=${SITEINFO_BITS} | ||
34 | oe_runmake 'LIB=lib/pseudo/lib$(MARK64)' | ||
35 | } | ||
36 | |||
37 | do_install () { | ||
38 | oe_runmake 'DESTDIR=${D}' 'LIB=lib/pseudo/lib$(MARK64)' install | ||
39 | if [ "${SITEINFO_BITS}" == "64" -a -e "/usr/include/gnu/stubs-32.h" -a "${PN}" == "pseudo-native" ]; then | ||
40 | mkdir -p ${D}${prefix}/lib/pseudo/lib | ||
41 | cp lib/pseudo/lib/libpseudo.so ${D}${prefix}/lib/pseudo/lib/. | ||
42 | fi | ||
43 | } | ||
44 | |||
45 | BBCLASSEXTEND = "native nativesdk" | ||
46 | |||
47 | |||