summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/prelink/prelink_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/prelink/prelink_git.bb')
-rw-r--r--meta/recipes-devtools/prelink/prelink_git.bb25
1 files changed, 22 insertions, 3 deletions
diff --git a/meta/recipes-devtools/prelink/prelink_git.bb b/meta/recipes-devtools/prelink/prelink_git.bb
index 1eea30a5f5..b57c145353 100644
--- a/meta/recipes-devtools/prelink/prelink_git.bb
+++ b/meta/recipes-devtools/prelink/prelink_git.bb
@@ -8,9 +8,24 @@ and executables, so that far fewer relocations need to be resolved at \
8runtime and thus programs come up faster." 8runtime and thus programs come up faster."
9LICENSE = "GPLv2" 9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b" 10LIC_FILES_CHKSUM = "file://COPYING;md5=c93c0550bd3173f4504b2cbd8991e50b"
11SRCREV = "909470ee441237563d6236c505cb2d02ddc48704" 11SRCREV = "ac461e73b17253a4da25c5aafeac7193b553156c"
12PV = "1.0+git${SRCPV}" 12PV = "1.0+git${SRCPV}"
13PR = "r2" 13PR = "r3"
14
15#
16# The cron script attempts to re-prelink the system daily -- on
17# systems where users are adding applications, this might be reasonable
18# but for embedded, we should be re-running prelink -a after an update.
19#
20# Default is prelinking is enabled.
21#
22SUMMARY_${PN}-cron = "Cron scripts to control automatic prelinking"
23DESCRIPTION_${PN}-cron = "Cron scripts to control automatic prelinking. \
24See: ${sysconfdir}/cron.daily/prelink for configuration information."
25
26FILES_${PN}-cron = "${sysconfdir}/cron.daily ${sysconfdir}/default"
27
28PACKAGES =+ "${PN}-cron"
14 29
15SRC_URI = "git://git.yoctoproject.org/prelink-cross.git;protocol=git \ 30SRC_URI = "git://git.yoctoproject.org/prelink-cross.git;protocol=git \
16 file://prelink.conf \ 31 file://prelink.conf \
@@ -53,9 +68,13 @@ fi
53prelink -a 68prelink -a
54} 69}
55 70
56pkg_postrm_prelink() { 71pkg_prerm_prelink() {
57#!/bin/sh 72#!/bin/sh
58 73
74if [ "x$D" != "x" ]; then
75 exit 1
76fi
77
59prelink -au 78prelink -au
60} 79}
61 80