summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/prelink/prelink_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/prelink/prelink_git.bb')
-rw-r--r--meta/recipes-devtools/prelink/prelink_git.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-devtools/prelink/prelink_git.bb b/meta/recipes-devtools/prelink/prelink_git.bb
new file mode 100644
index 0000000000..06078ed68b
--- /dev/null
+++ b/meta/recipes-devtools/prelink/prelink_git.bb
@@ -0,0 +1,50 @@
1SECTION = "devel"
2# Need binutils for libiberty.a
3DEPENDS = "elfutils binutils"
4DESCRIPTION = " The prelink package contains a utility which modifies ELF shared libraries \
5and executables, so that far fewer relocations need to be resolved at \
6runtime and thus programs come up faster."
7LICENSE = "GPLv2"
8PV = "1.0+git${SRCPV}"
9PR = "r0"
10
11SRC_URI = "git://git.pokylinux.org/prelink-cross.git;protocol=git \
12 file://prelink.conf \
13 file://prelink.cron.daily \
14 file://prelink.default"
15
16TARGET_OS_ORIG := "${TARGET_OS}"
17OVERRIDES_append = ":${TARGET_OS_ORIG}"
18
19S = "${WORKDIR}/git/trunk"
20
21inherit autotools
22
23BBCLASSEXTEND = "native"
24
25EXTRA_OECONF = "--disable-selinux --with-pkgversion=${PV}-${PR} \
26 --with-bugurl=http://bugzilla.pokylinux.org/"
27
28do_install_append () {
29 install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
30 install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf
31 install -m 0644 ${WORKDIR}/prelink.cron.daily ${D}${sysconfdir}/cron.daily/prelink
32 install -m 0644 ${WORKDIR}/prelink.default ${D}${sysconfdir}/default/prelink
33}
34
35pkg_postinst_prelink() {
36#!/bin/sh
37
38if [ "x$D" != "x" ]; then
39 exit 1
40fi
41
42prelink -a
43}
44
45pkg_postrm_prelink() {
46#!/bin/sh
47
48prelink -au
49}
50