summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/postinst-intercept/postinst-intercept_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/postinst-intercept/postinst-intercept_1.0.bb')
-rw-r--r--meta/recipes-devtools/postinst-intercept/postinst-intercept_1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/postinst-intercept/postinst-intercept_1.0.bb b/meta/recipes-devtools/postinst-intercept/postinst-intercept_1.0.bb
new file mode 100644
index 0000000000..41b9a6e49e
--- /dev/null
+++ b/meta/recipes-devtools/postinst-intercept/postinst-intercept_1.0.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Postinstall scriptlets"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5FILES_${PN}_append_class-nativesdk = " ${datadir}/postinst-intercepts/*"
6
7do_configure[noexec] = "1"
8do_compile[noexec] = "1"
9
10do_install_append_class-nativesdk() {
11 install -d ${D}${datadir}/postinst-intercepts
12 install -m 755 ${COREBASE}/scripts/postinst-intercepts/postinst_intercept ${D}${datadir}/postinst-intercepts/
13 install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_font_cache ${D}${datadir}/postinst-intercepts/
14 install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_icon_cache ${D}${datadir}/postinst-intercepts/
15 install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_pixbuf_cache ${D}${datadir}/postinst-intercepts/
16}
17
18BBCLASSEXTEND = "nativesdk"
19INHIBIT_DEFAULT_DEPS = "1"