diff options
Diffstat (limited to 'meta/recipes-devtools/pkgconf/pkgconf_2.0.2.bb')
-rw-r--r-- | meta/recipes-devtools/pkgconf/pkgconf_2.0.2.bb | 67 |
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pkgconf/pkgconf_2.0.2.bb b/meta/recipes-devtools/pkgconf/pkgconf_2.0.2.bb new file mode 100644 index 0000000000..c6badb123e --- /dev/null +++ b/meta/recipes-devtools/pkgconf/pkgconf_2.0.2.bb | |||
@@ -0,0 +1,67 @@ | |||
1 | SUMMARY = "pkgconf provides compiler and linker configuration for development frameworks." | ||
2 | DESCRIPTION = "pkgconf is a program which helps to configure compiler and linker \ | ||
3 | flags for development frameworks. It is similar to pkg-config from \ | ||
4 | freedesktop.org, providing additional functionality while also maintaining \ | ||
5 | compatibility." | ||
6 | HOMEPAGE = "http://pkgconf.org" | ||
7 | BUGTRACKER = "https://github.com/pkgconf/pkgconf/issues" | ||
8 | SECTION = "devel" | ||
9 | PROVIDES += "pkgconfig" | ||
10 | RPROVIDES:${PN} += "pkgconfig" | ||
11 | |||
12 | # The pkgconf license seems to be functionally equivalent to BSD-2-Clause or | ||
13 | # ISC, but has different wording, so needs its own name. | ||
14 | LICENSE = "pkgconf" | ||
15 | LIC_FILES_CHKSUM = "file://COPYING;md5=2214222ec1a820bd6cc75167a56925e0" | ||
16 | |||
17 | SRC_URI = "\ | ||
18 | https://distfiles.ariadne.space/pkgconf/pkgconf-${PV}.tar.xz \ | ||
19 | file://pkg-config-wrapper \ | ||
20 | file://pkg-config-native.in \ | ||
21 | file://pkg-config-esdk.in \ | ||
22 | " | ||
23 | SRC_URI[sha256sum] = "ea5a25ef8f251eb5377ec0e21c75fb61894433cfbdbf0b2559ba33e4c2664401" | ||
24 | |||
25 | inherit autotools | ||
26 | |||
27 | EXTRA_OECONF += "--with-pkg-config-dir='${libdir}/pkgconfig:${datadir}/pkgconfig'" | ||
28 | |||
29 | do_install:append () { | ||
30 | # Install a wrapper which deals, as much as possible with pkgconf vs | ||
31 | # pkg-config compatibility issues. | ||
32 | install -m 0755 "${WORKDIR}/pkg-config-wrapper" "${D}${bindir}/pkg-config" | ||
33 | } | ||
34 | |||
35 | do_install:append:class-native () { | ||
36 | # Install a pkg-config-native wrapper that will use the native sysroot instead | ||
37 | # of the MACHINE sysroot, for using pkg-config when building native tools. | ||
38 | sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \ | ||
39 | < ${WORKDIR}/pkg-config-native.in > ${B}/pkg-config-native | ||
40 | install -m755 ${B}/pkg-config-native ${D}${bindir}/pkg-config-native | ||
41 | sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \ | ||
42 | -e "s|@LIBDIR_NATIVE@|${PKG_CONFIG_LIBDIR}|" \ | ||
43 | < ${WORKDIR}/pkg-config-esdk.in > ${B}/pkg-config-esdk | ||
44 | install -m755 ${B}/pkg-config-esdk ${D}${bindir}/pkg-config-esdk | ||
45 | } | ||
46 | |||
47 | # When using the RPM generated automatic package dependencies, some packages | ||
48 | # will end up requiring 'pkgconfig(pkg-config)'. Allow this behavior by | ||
49 | # specifying an appropriate provide. | ||
50 | RPROVIDES:${PN} += "pkgconfig(pkg-config)" | ||
51 | |||
52 | # Include pkg.m4 in the main package, leaving libpkgconf dev files in -dev | ||
53 | FILES:${PN}-dev:remove = "${datadir}/aclocal" | ||
54 | FILES:${PN} += "${datadir}/aclocal" | ||
55 | |||
56 | BBCLASSEXTEND += "native nativesdk" | ||
57 | |||
58 | pkgconf_sstate_fixup_esdk () { | ||
59 | if [ "${BB_CURRENTTASK}" = "populate_sysroot_setscene" -a "${WITHIN_EXT_SDK}" = "1" ] ; then | ||
60 | pkgconfdir="${SSTATE_INSTDIR}/recipe-sysroot-native/${bindir_native}" | ||
61 | mv $pkgconfdir/pkg-config $pkgconfdir/pkg-config.real | ||
62 | ln -rs $pkgconfdir/pkg-config-esdk $pkgconfdir/pkg-config | ||
63 | sed -i -e "s|^pkg-config|pkg-config.real|" $pkgconfdir/pkg-config-native | ||
64 | fi | ||
65 | } | ||
66 | |||
67 | SSTATEPOSTUNPACKFUNCS:append:class-native = " pkgconf_sstate_fixup_esdk" | ||