summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pkgconf/pkgconf_1.7.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/pkgconf/pkgconf_1.7.4.bb')
-rw-r--r--meta/recipes-devtools/pkgconf/pkgconf_1.7.4.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-devtools/pkgconf/pkgconf_1.7.4.bb b/meta/recipes-devtools/pkgconf/pkgconf_1.7.4.bb
index 93832105f0..04991b1f01 100644
--- a/meta/recipes-devtools/pkgconf/pkgconf_1.7.4.bb
+++ b/meta/recipes-devtools/pkgconf/pkgconf_1.7.4.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "http://pkgconf.org"
7BUGTRACKER = "https://github.com/pkgconf/pkgconf/issues" 7BUGTRACKER = "https://github.com/pkgconf/pkgconf/issues"
8SECTION = "devel" 8SECTION = "devel"
9PROVIDES += "pkgconfig" 9PROVIDES += "pkgconfig"
10RPROVIDES_${PN} += "pkgconfig" 10RPROVIDES:${PN} += "pkgconfig"
11 11
12# The pkgconf license seems to be functionally equivalent to BSD-2-Clause or 12# The pkgconf license seems to be functionally equivalent to BSD-2-Clause or
13# ISC, but has different wording, so needs its own name. 13# ISC, but has different wording, so needs its own name.
@@ -26,13 +26,13 @@ inherit autotools
26 26
27EXTRA_OECONF += "--with-pkg-config-dir='${libdir}/pkgconfig:${datadir}/pkgconfig'" 27EXTRA_OECONF += "--with-pkg-config-dir='${libdir}/pkgconfig:${datadir}/pkgconfig'"
28 28
29do_install_append () { 29do_install:append () {
30 # Install a wrapper which deals, as much as possible with pkgconf vs 30 # Install a wrapper which deals, as much as possible with pkgconf vs
31 # pkg-config compatibility issues. 31 # pkg-config compatibility issues.
32 install -m 0755 "${WORKDIR}/pkg-config-wrapper" "${D}${bindir}/pkg-config" 32 install -m 0755 "${WORKDIR}/pkg-config-wrapper" "${D}${bindir}/pkg-config"
33} 33}
34 34
35do_install_append_class-native () { 35do_install:append:class-native () {
36 # Install a pkg-config-native wrapper that will use the native sysroot instead 36 # Install a pkg-config-native wrapper that will use the native sysroot instead
37 # of the MACHINE sysroot, for using pkg-config when building native tools. 37 # of the MACHINE sysroot, for using pkg-config when building native tools.
38 sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \ 38 sed -e "s|@PATH_NATIVE@|${PKG_CONFIG_PATH}|" \
@@ -47,11 +47,11 @@ do_install_append_class-native () {
47# When using the RPM generated automatic package dependencies, some packages 47# When using the RPM generated automatic package dependencies, some packages
48# will end up requiring 'pkgconfig(pkg-config)'. Allow this behavior by 48# will end up requiring 'pkgconfig(pkg-config)'. Allow this behavior by
49# specifying an appropriate provide. 49# specifying an appropriate provide.
50RPROVIDES_${PN} += "pkgconfig(pkg-config)" 50RPROVIDES:${PN} += "pkgconfig(pkg-config)"
51 51
52# Include pkg.m4 in the main package, leaving libpkgconf dev files in -dev 52# Include pkg.m4 in the main package, leaving libpkgconf dev files in -dev
53FILES_${PN}-dev_remove = "${datadir}/aclocal" 53FILES:${PN}-dev:remove = "${datadir}/aclocal"
54FILES_${PN} += "${datadir}/aclocal" 54FILES:${PN} += "${datadir}/aclocal"
55 55
56BBCLASSEXTEND += "native nativesdk" 56BBCLASSEXTEND += "native nativesdk"
57 57
@@ -64,4 +64,4 @@ pkgconf_sstate_fixup_esdk () {
64 fi 64 fi
65} 65}
66 66
67SSTATEPOSTUNPACKFUNCS_append_class-native = " pkgconf_sstate_fixup_esdk" 67SSTATEPOSTUNPACKFUNCS:append:class-native = " pkgconf_sstate_fixup_esdk"