diff options
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.34.0.bb')
-rw-r--r-- | meta/recipes-devtools/perl/perl_5.34.0.bb | 62 |
1 files changed, 31 insertions, 31 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.34.0.bb b/meta/recipes-devtools/perl/perl_5.34.0.bb index 434535c5ee..cc01321f7a 100644 --- a/meta/recipes-devtools/perl/perl_5.34.0.bb +++ b/meta/recipes-devtools/perl/perl_5.34.0.bb | |||
@@ -18,10 +18,10 @@ SRC_URI = "https://www.cpan.org/src/5.0/perl-${PV}.tar.gz;name=perl \ | |||
18 | file://0002-Constant-Fix-up-shebang.patch \ | 18 | file://0002-Constant-Fix-up-shebang.patch \ |
19 | file://determinism.patch \ | 19 | file://determinism.patch \ |
20 | " | 20 | " |
21 | SRC_URI_append_class-native = " \ | 21 | SRC_URI:append:class-native = " \ |
22 | file://perl-configpm-switch.patch \ | 22 | file://perl-configpm-switch.patch \ |
23 | " | 23 | " |
24 | SRC_URI_append_class-target = " \ | 24 | SRC_URI:append:class-target = " \ |
25 | file://encodefix.patch \ | 25 | file://encodefix.patch \ |
26 | " | 26 | " |
27 | 27 | ||
@@ -42,11 +42,11 @@ PACKAGECONFIG[gdbm] = ",-Ui_gdbm,gdbm" | |||
42 | # Don't generate comments in enc2xs output files. They are not reproducible | 42 | # Don't generate comments in enc2xs output files. They are not reproducible |
43 | export ENC2XS_NO_COMMENTS = "1" | 43 | export ENC2XS_NO_COMMENTS = "1" |
44 | 44 | ||
45 | do_configure_prepend() { | 45 | do_configure:prepend() { |
46 | cp -rfp ${STAGING_DATADIR_NATIVE}/perl-cross/* ${S} | 46 | cp -rfp ${STAGING_DATADIR_NATIVE}/perl-cross/* ${S} |
47 | } | 47 | } |
48 | 48 | ||
49 | do_configure_class-target() { | 49 | do_configure:class-target() { |
50 | ./configure --prefix=${prefix} --libdir=${libdir} \ | 50 | ./configure --prefix=${prefix} --libdir=${libdir} \ |
51 | --target=${TARGET_SYS} \ | 51 | --target=${TARGET_SYS} \ |
52 | -Duseshrplib \ | 52 | -Duseshrplib \ |
@@ -72,7 +72,7 @@ do_configure_class-target() { | |||
72 | sed -i -e "s,${STAGING_LIBDIR},${libdir},g" config.h | 72 | sed -i -e "s,${STAGING_LIBDIR},${libdir},g" config.h |
73 | } | 73 | } |
74 | 74 | ||
75 | do_configure_class-nativesdk() { | 75 | do_configure:class-nativesdk() { |
76 | ./configure --prefix=${prefix} \ | 76 | ./configure --prefix=${prefix} \ |
77 | --target=${TARGET_SYS} \ | 77 | --target=${TARGET_SYS} \ |
78 | -Duseshrplib \ | 78 | -Duseshrplib \ |
@@ -85,7 +85,7 @@ do_configure_class-nativesdk() { | |||
85 | sed -i -e "s,${STAGING_LIBDIR},${libdir},g" config.h | 85 | sed -i -e "s,${STAGING_LIBDIR},${libdir},g" config.h |
86 | } | 86 | } |
87 | 87 | ||
88 | do_configure_class-native() { | 88 | do_configure:class-native() { |
89 | ./configure --prefix=${prefix} \ | 89 | ./configure --prefix=${prefix} \ |
90 | -Dbin=${bindir}/perl-native \ | 90 | -Dbin=${bindir}/perl-native \ |
91 | -Duseshrplib \ | 91 | -Duseshrplib \ |
@@ -95,7 +95,7 @@ do_configure_class-native() { | |||
95 | ${PACKAGECONFIG_CONFARGS} | 95 | ${PACKAGECONFIG_CONFARGS} |
96 | } | 96 | } |
97 | 97 | ||
98 | do_configure_append() { | 98 | do_configure:append() { |
99 | if [ -n "$SOURCE_DATE_EPOCH" ]; then | 99 | if [ -n "$SOURCE_DATE_EPOCH" ]; then |
100 | PERL_BUILD_DATE="$(${PYTHON} -c "\ | 100 | PERL_BUILD_DATE="$(${PYTHON} -c "\ |
101 | from datetime import datetime, timezone; \ | 101 | from datetime import datetime, timezone; \ |
@@ -140,7 +140,7 @@ do_install() { | |||
140 | fi | 140 | fi |
141 | } | 141 | } |
142 | 142 | ||
143 | do_install_append_class-target() { | 143 | do_install:append:class-target() { |
144 | # This is used to substitute target configuration when running native perl via perl-configpm-switch.patch | 144 | # This is used to substitute target configuration when running native perl via perl-configpm-switch.patch |
145 | ln -s Config_heavy.pl ${D}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_heavy-target.pl | 145 | ln -s Config_heavy.pl ${D}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_heavy-target.pl |
146 | 146 | ||
@@ -149,7 +149,7 @@ do_install_append_class-target() { | |||
149 | rm ${D}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/xconfig.h | 149 | rm ${D}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/CORE/xconfig.h |
150 | } | 150 | } |
151 | 151 | ||
152 | do_install_append_class-nativesdk() { | 152 | do_install:append:class-nativesdk() { |
153 | # This is used to substitute target configuration when running native perl via perl-configpm-switch.patch | 153 | # This is used to substitute target configuration when running native perl via perl-configpm-switch.patch |
154 | ln -s Config_heavy.pl ${D}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_heavy-target.pl | 154 | ln -s Config_heavy.pl ${D}${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config_heavy-target.pl |
155 | 155 | ||
@@ -157,7 +157,7 @@ do_install_append_class-nativesdk() { | |||
157 | PERL5LIB='$PERL5LIB:${SDKPATHNATIVE}/${libdir_nativesdk}/perl5/site_perl/${PV}:${SDKPATHNATIVE}/${libdir_nativesdk}/perl5/vendor_perl/${PV}:${SDKPATHNATIVE}/${libdir_nativesdk}/perl5/${PV}' | 157 | PERL5LIB='$PERL5LIB:${SDKPATHNATIVE}/${libdir_nativesdk}/perl5/site_perl/${PV}:${SDKPATHNATIVE}/${libdir_nativesdk}/perl5/vendor_perl/${PV}:${SDKPATHNATIVE}/${libdir_nativesdk}/perl5/${PV}' |
158 | } | 158 | } |
159 | 159 | ||
160 | do_install_append_class-native () { | 160 | do_install:append:class-native () { |
161 | # Those wrappers mean that perl installed from sstate (which may change | 161 | # Those wrappers mean that perl installed from sstate (which may change |
162 | # path location) works and that in the nativesdk case, the SDK can be | 162 | # path location) works and that in the nativesdk case, the SDK can be |
163 | # installed to a different location from the one it was built for. | 163 | # installed to a different location from the one it was built for. |
@@ -208,7 +208,7 @@ inherit update-alternatives | |||
208 | 208 | ||
209 | ALTERNATIVE_PRIORITY = "100" | 209 | ALTERNATIVE_PRIORITY = "100" |
210 | 210 | ||
211 | ALTERNATIVE_${PN}-misc = "corelist cpan enc2xs encguess h2ph h2xs instmodsh json_pp libnetcfg \ | 211 | ALTERNATIVE:${PN}-misc = "corelist cpan enc2xs encguess h2ph h2xs instmodsh json_pp libnetcfg \ |
212 | piconv pl2pm pod2html pod2man pod2text pod2usage podchecker \ | 212 | piconv pl2pm pod2html pod2man pod2text pod2usage podchecker \ |
213 | prove ptar ptardiff ptargrep shasum splain xsubpp zipdetails" | 213 | prove ptar ptardiff ptargrep shasum splain xsubpp zipdetails" |
214 | ALTERNATIVE_LINK_NAME[corelist] = "${bindir}/corelist" | 214 | ALTERNATIVE_LINK_NAME[corelist] = "${bindir}/corelist" |
@@ -238,7 +238,7 @@ ALTERNATIVE_LINK_NAME[zipdetails] = "${bindir}/zipdetails" | |||
238 | 238 | ||
239 | require perl-ptest.inc | 239 | require perl-ptest.inc |
240 | 240 | ||
241 | FILES_${PN} = "${bindir}/perl ${bindir}/perl.real ${bindir}/perl${PV} ${libdir}/libperl.so* \ | 241 | FILES:${PN} = "${bindir}/perl ${bindir}/perl.real ${bindir}/perl${PV} ${libdir}/libperl.so* \ |
242 | ${libdir}/perl5/site_perl \ | 242 | ${libdir}/perl5/site_perl \ |
243 | ${libdir}/perl5/${PV}/Config.pm \ | 243 | ${libdir}/perl5/${PV}/Config.pm \ |
244 | ${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config.pm \ | 244 | ${libdir}/perl5/${PV}/${TARGET_ARCH}-linux/Config.pm \ |
@@ -254,24 +254,24 @@ FILES_${PN} = "${bindir}/perl ${bindir}/perl.real ${bindir}/perl${PV} ${libdir}/ | |||
254 | ${libdir}/perl5/${PV}/ExtUtils/xsubpp \ | 254 | ${libdir}/perl5/${PV}/ExtUtils/xsubpp \ |
255 | ${libdir}/perl5/${PV}/ExtUtils/typemap \ | 255 | ${libdir}/perl5/${PV}/ExtUtils/typemap \ |
256 | " | 256 | " |
257 | RPROVIDES_${PN} += "perl-module-strict perl-module-vars perl-module-config perl-module-warnings \ | 257 | RPROVIDES:${PN} += "perl-module-strict perl-module-vars perl-module-config perl-module-warnings \ |
258 | perl-module-warnings-register" | 258 | perl-module-warnings-register" |
259 | 259 | ||
260 | FILES_${PN}-staticdev_append = " ${libdir}/perl5/${PV}/*/CORE/libperl.a" | 260 | FILES:${PN}-staticdev:append = " ${libdir}/perl5/${PV}/*/CORE/libperl.a" |
261 | 261 | ||
262 | FILES_${PN}-dev_append = " ${libdir}/perl5/${PV}/*/CORE" | 262 | FILES:${PN}-dev:append = " ${libdir}/perl5/${PV}/*/CORE" |
263 | 263 | ||
264 | FILES_${PN}-doc_append = " ${libdir}/perl5/${PV}/Unicode/Collate/*.txt \ | 264 | FILES:${PN}-doc:append = " ${libdir}/perl5/${PV}/Unicode/Collate/*.txt \ |
265 | ${libdir}/perl5/${PV}/*/.packlist \ | 265 | ${libdir}/perl5/${PV}/*/.packlist \ |
266 | ${libdir}/perl5/${PV}/Encode/encode.h \ | 266 | ${libdir}/perl5/${PV}/Encode/encode.h \ |
267 | " | 267 | " |
268 | PACKAGES += "${PN}-misc" | 268 | PACKAGES += "${PN}-misc" |
269 | 269 | ||
270 | FILES_${PN}-misc = "${bindir}/*" | 270 | FILES:${PN}-misc = "${bindir}/*" |
271 | 271 | ||
272 | PACKAGES += "${PN}-pod" | 272 | PACKAGES += "${PN}-pod" |
273 | 273 | ||
274 | FILES_${PN}-pod = "${libdir}/perl5/${PV}/pod \ | 274 | FILES:${PN}-pod = "${libdir}/perl5/${PV}/pod \ |
275 | ${libdir}/perl5/${PV}/*.pod \ | 275 | ${libdir}/perl5/${PV}/*.pod \ |
276 | ${libdir}/perl5/${PV}/*/*.pod \ | 276 | ${libdir}/perl5/${PV}/*/*.pod \ |
277 | ${libdir}/perl5/${PV}/*/*/*.pod \ | 277 | ${libdir}/perl5/${PV}/*/*/*.pod \ |
@@ -280,20 +280,20 @@ FILES_${PN}-pod = "${libdir}/perl5/${PV}/pod \ | |||
280 | 280 | ||
281 | PACKAGES += "${PN}-module-cpan ${PN}-module-unicore" | 281 | PACKAGES += "${PN}-module-cpan ${PN}-module-unicore" |
282 | 282 | ||
283 | FILES_${PN}-module-cpan += "${libdir}/perl5/${PV}/CPAN \ | 283 | FILES:${PN}-module-cpan += "${libdir}/perl5/${PV}/CPAN \ |
284 | " | 284 | " |
285 | FILES_${PN}-module-unicore += "${libdir}/perl5/${PV}/unicore" | 285 | FILES:${PN}-module-unicore += "${libdir}/perl5/${PV}/unicore" |
286 | 286 | ||
287 | ALTERNATIVE_PRIORITY = "40" | 287 | ALTERNATIVE_PRIORITY = "40" |
288 | ALTERNATIVE_${PN}-doc = "Thread.3" | 288 | ALTERNATIVE:${PN}-doc = "Thread.3" |
289 | ALTERNATIVE_LINK_NAME[Thread.3] = "${mandir}/man3/Thread.3" | 289 | ALTERNATIVE_LINK_NAME[Thread.3] = "${mandir}/man3/Thread.3" |
290 | 290 | ||
291 | # Create a perl-modules package recommending all the other perl | 291 | # Create a perl-modules package recommending all the other perl |
292 | # packages (actually the non modules packages and not created too) | 292 | # packages (actually the non modules packages and not created too) |
293 | ALLOW_EMPTY_${PN}-modules = "1" | 293 | ALLOW_EMPTY:${PN}-modules = "1" |
294 | PACKAGES += "${PN}-modules " | 294 | PACKAGES += "${PN}-modules " |
295 | 295 | ||
296 | PACKAGESPLITFUNCS_prepend = "split_perl_packages " | 296 | PACKAGESPLITFUNCS:prepend = "split_perl_packages " |
297 | 297 | ||
298 | python split_perl_packages () { | 298 | python split_perl_packages () { |
299 | libdir = d.expand('${libdir}/perl5/${PV}') | 299 | libdir = d.expand('${libdir}/perl5/${PV}') |
@@ -308,7 +308,7 @@ python split_perl_packages () { | |||
308 | # modules. Don't attempt to use the result of do_split_packages() as some | 308 | # modules. Don't attempt to use the result of do_split_packages() as some |
309 | # modules are manually split (eg. perl-module-unicore). | 309 | # modules are manually split (eg. perl-module-unicore). |
310 | packages = filter(lambda p: 'perl-module-' in p, d.getVar('PACKAGES').split()) | 310 | packages = filter(lambda p: 'perl-module-' in p, d.getVar('PACKAGES').split()) |
311 | d.setVar(d.expand("RRECOMMENDS_${PN}-modules"), ' '.join(packages)) | 311 | d.setVar(d.expand("RRECOMMENDS:${PN}-modules"), ' '.join(packages)) |
312 | 312 | ||
313 | # Read the pre-generated dependency file, and use it to set module dependecies | 313 | # Read the pre-generated dependency file, and use it to set module dependecies |
314 | for line in open(d.expand("${WORKDIR}") + '/perl-rdepends.txt').readlines(): | 314 | for line in open(d.expand("${WORKDIR}") + '/perl-rdepends.txt').readlines(): |
@@ -320,7 +320,7 @@ python split_perl_packages () { | |||
320 | module = splitline[0] + '-native' | 320 | module = splitline[0] + '-native' |
321 | depends = "perl-native" | 321 | depends = "perl-native" |
322 | else: | 322 | else: |
323 | module = splitline[0].replace("RDEPENDS_perl", "RDEPENDS_${PN}") | 323 | module = splitline[0].replace("RDEPENDS:perl", "RDEPENDS:${PN}") |
324 | depends = splitline[2].strip('"').replace("perl-module", "${PN}-module") | 324 | depends = splitline[2].strip('"').replace("perl-module", "${PN}-module") |
325 | d.appendVar(d.expand(module), " " + depends) | 325 | d.appendVar(d.expand(module), " " + depends) |
326 | } | 326 | } |
@@ -334,8 +334,8 @@ python() { | |||
334 | d.setVar("PACKAGES_DYNAMIC", "^nativesdk-perl-module-.*") | 334 | d.setVar("PACKAGES_DYNAMIC", "^nativesdk-perl-module-.*") |
335 | } | 335 | } |
336 | 336 | ||
337 | RDEPENDS_${PN}-misc += "perl perl-modules" | 337 | RDEPENDS:${PN}-misc += "perl perl-modules" |
338 | RDEPENDS_${PN}-pod += "perl" | 338 | RDEPENDS:${PN}-pod += "perl" |
339 | 339 | ||
340 | BBCLASSEXTEND = "native nativesdk" | 340 | BBCLASSEXTEND = "native nativesdk" |
341 | 341 | ||
@@ -346,10 +346,10 @@ do_create_rdepends_inc() { | |||
346 | cat <<'EOPREAMBLE' > ${WORKDIR}/perl-rdepends.inc | 346 | cat <<'EOPREAMBLE' > ${WORKDIR}/perl-rdepends.inc |
347 | 347 | ||
348 | # Some additional dependencies that the above doesn't manage to figure out | 348 | # Some additional dependencies that the above doesn't manage to figure out |
349 | RDEPENDS_${PN}-module-file-spec += "${PN}-module-file-spec-unix" | 349 | RDEPENDS:${PN}-module-file-spec += "${PN}-module-file-spec-unix" |
350 | RDEPENDS_${PN}-module-math-bigint += "${PN}-module-math-bigint-calc" | 350 | RDEPENDS:${PN}-module-math-bigint += "${PN}-module-math-bigint-calc" |
351 | RDEPENDS_${PN}-module-thread-queue += "${PN}-module-attributes" | 351 | RDEPENDS:${PN}-module-thread-queue += "${PN}-module-attributes" |
352 | RDEPENDS_${PN}-module-overload += "${PN}-module-overloading" | 352 | RDEPENDS:${PN}-module-overload += "${PN}-module-overloading" |
353 | 353 | ||
354 | # Generated depends list beyond this line | 354 | # Generated depends list beyond this line |
355 | EOPREAMBLE | 355 | EOPREAMBLE |