summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.24.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.24.1.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.24.1.bb22
1 files changed, 0 insertions, 22 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.24.1.bb b/meta/recipes-devtools/perl/perl_5.24.1.bb
index cf7a8e1218..b0ceb84912 100644
--- a/meta/recipes-devtools/perl/perl_5.24.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.24.1.bb
@@ -124,28 +124,6 @@ do_configure() {
124 cat $i >> config.sh-${TARGET_ARCH}-${TARGET_OS} 124 cat $i >> config.sh-${TARGET_ARCH}-${TARGET_OS}
125 done 125 done
126 126
127 # Fixups for uclibc
128 if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
129 sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \
130 -e "s,\(d_futimes=\)'define',\1'undef',g" \
131 -e "s,\(d_finitel=\)'define',\1'undef',g" \
132 -e "s,\(crypt_r_proto=\)'\w+',\1'0',g" \
133 -e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \
134 -e "s,\(getnetbyname_r_proto=\)'\w+',\1'0',g" \
135 -e "s,\(d_getnetbyaddr_r=\)'define',\1'undef',g" \
136 -e "s,\(getnetbyaddr_r_proto=\)'\w+',\1'0',g" \
137 -e "s,\(d_getnetent_r=\)'define',\1'undef',g" \
138 -e "s,\(getnetent_r_proto=\)'\w+',\1'0',g" \
139 -e "s,\(d_sockatmark=\)'define',\1'undef',g" \
140 -e "s,\(d_sockatmarkproto=\)'\w+',\1'0',g" \
141 -e "s,\(d_eaccess=\)'define',\1'undef',g" \
142 -e "s,\(d_stdio_ptr_lval=\)'define',\1'undef',g" \
143 -e "s,\(d_stdio_ptr_lval_sets_cnt=\)'define',\1'undef',g" \
144 -e "s,\(d_stdiobase=\)'define',\1'undef',g" \
145 -e "s,\(d_stdstdio=\)'define',\1'undef',g" \
146 -e "s,-fstack-protector,-fno-stack-protector,g" \
147 config.sh-${TARGET_ARCH}-${TARGET_OS}
148 fi
149 # Fixups for musl 127 # Fixups for musl
150 if [ "${TARGET_OS}" = "linux-musl" -o "${TARGET_OS}" = "linux-musleabi" ]; then 128 if [ "${TARGET_OS}" = "linux-musl" -o "${TARGET_OS}" = "linux-musleabi" ]; then
151 sed -i -e "s,\(d_libm_lib_version=\)'define',\1'undef',g" \ 129 sed -i -e "s,\(d_libm_lib_version=\)'define',\1'undef',g" \