summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.8.8.bb')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.8.8.bb93
1 files changed, 93 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.8.8.bb b/meta/recipes-devtools/perl/perl-native_5.8.8.bb
new file mode 100644
index 0000000000..534b6700df
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-native_5.8.8.bb
@@ -0,0 +1,93 @@
1DESCRIPTION = "Perl is a popular scripting language."
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "libs"
4LICENSE = "Artistic|GPL"
5DEPENDS = "virtual/db-native gdbm-native"
6PR = "r14"
7
8SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
9 file://perl-5.8.8-gcc-4.2.patch;patch=1 \
10 file://Configure-multilib.patch;patch=1 \
11 file://perl-configpm-switch.patch;patch=1 \
12 file://native-nopacklist.patch;patch=1 \
13 file://native-no-gdbminc.patch;patch=1 \
14 file://native-perlinc.patch;patch=1 \
15 file://makedepend-dash.patch;patch=1 \
16 file://asm-pageh-fix.patch;patch=1"
17
18S = "${WORKDIR}/perl-${PV}"
19
20inherit native
21
22do_configure () {
23 ./Configure \
24 -Dcc="${CC}" \
25 -Dcflags="${CFLAGS}" \
26 -Dldflags="${LDFLAGS}" \
27 -Dcf_by="Open Embedded" \
28 -Dprefix=${prefix} \
29 -Dvendorprefix=${prefix} \
30 -Dvendorprefix=${prefix} \
31 -Dsiteprefix=${prefix} \
32 \
33 -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
34 -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
35 -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
36 -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
37 -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
38 -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
39 \
40 -Duseshrplib \
41 -Dusethreads \
42 -Duseithreads \
43 -Duselargefiles \
44 -Dnoextensions=ODBM_File \
45 -Ud_dosuid \
46 -Ui_db \
47 -Ui_ndbm \
48 -Ui_gdbm \
49 -Di_shadow \
50 -Di_syslog \
51 -Duseperlio \
52 -Dman3ext=3pm \
53 -Uafs \
54 -Ud_csh \
55 -Uusesfio \
56 -Uusenm -des
57}
58
59do_install () {
60 oe_runmake 'DESTDIR=${D}' install
61
62 # We need a hostperl link for building perl
63 ln -sf perl${PV} ${D}${bindir}/hostperl
64
65 install -d ${D}${libdir}/perl/${PV}/CORE \
66 ${D}${datadir}/perl/${PV}/ExtUtils
67
68 # Save native config
69 install config.sh ${D}${libdir}/perl
70 install lib/Config.pm ${D}${libdir}/perl/${PV}/
71 install lib/ExtUtils/typemap ${D}${datadir}/perl/${PV}/ExtUtils/
72
73 # perl shared library headers
74 for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
75 uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \
76 perliol.h pp_proto.h regnodes.h unixish.h config.h EXTERN.h \
77 hv.h malloc_ctl.h pad.h perlsdio.h proto.h scope.h utf8.h \
78 cop.h fakesdio.h INTERN.h mg.h patchlevel.h perlsfio.h \
79 reentr.h sv.h utfebcdic.h cv.h fakethr.h intrpvar.h \
80 nostdio.h perlapi.h perlvars.h reentr.inc thrdvar.h util.h \
81 dosish.h form.h iperlsys.h opcode.h perl.h perly.h regcomp.h \
82 thread.h warnings.h; do
83 install $i ${D}${libdir}/perl/${PV}/CORE
84 done
85}
86do_install_append_nylon() {
87 # get rid of definitions not supported by the gcc version we use for nylon...
88 for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do
89 perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
90 done
91}
92
93PARALLEL_MAKE = ""