summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.8.8.bb')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.8.8.bb104
1 files changed, 0 insertions, 104 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.8.8.bb b/meta/recipes-devtools/perl/perl-native_5.8.8.bb
deleted file mode 100644
index cc946af255..0000000000
--- a/meta/recipes-devtools/perl/perl-native_5.8.8.bb
+++ /dev/null
@@ -1,104 +0,0 @@
1DESCRIPTION = "Perl is a popular scripting language."
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "libs"
4LICENSE = "Artistic|GPL"
5DEPENDS = "virtual/db-native gdbm-native"
6PR = "r14"
7
8LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
9 file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
10
11SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
12 file://perl-5.8.8-gcc-4.2.patch;patch=1 \
13 file://Configure-multilib.patch;patch=1 \
14 file://perl-configpm-switch.patch;patch=1 \
15 file://native-nopacklist.patch;patch=1 \
16 file://native-no-gdbminc.patch;patch=1 \
17 file://native-perlinc.patch;patch=1 \
18 file://makedepend-dash.patch;patch=1 \
19 file://asm-pageh-fix.patch;patch=1"
20
21SRC_URI[md5sum] = "b8c118d4360846829beb30b02a6b91a7"
22SRC_URI[sha256sum] = "e15d499321e003d12ed183601e37ee7ba5f64b278d1de30149ce01bd4a3f234d"
23
24S = "${WORKDIR}/perl-${PV}"
25
26inherit native
27
28do_configure () {
29 ./Configure \
30 -Dcc="${CC}" \
31 -Dcflags="${CFLAGS}" \
32 -Dldflags="${LDFLAGS}" \
33 -Dcf_by="Open Embedded" \
34 -Dprefix=${prefix} \
35 -Dvendorprefix=${prefix} \
36 -Dvendorprefix=${prefix} \
37 -Dsiteprefix=${prefix} \
38 \
39 -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
40 -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
41 -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
42 -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
43 -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
44 -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
45 \
46 -Duseshrplib \
47 -Dusethreads \
48 -Duseithreads \
49 -Duselargefiles \
50 -Dnoextensions=ODBM_File \
51 -Ud_dosuid \
52 -Ui_db \
53 -Ui_ndbm \
54 -Ui_gdbm \
55 -Di_shadow \
56 -Di_syslog \
57 -Duseperlio \
58 -Dman3ext=3pm \
59 -Uafs \
60 -Ud_csh \
61 -Uusesfio \
62 -Uusenm -des
63}
64
65do_install () {
66 oe_runmake 'DESTDIR=${D}' install
67
68 # We need a hostperl link for building perl
69 ln -sf perl${PV} ${D}${bindir}/hostperl
70
71 install -d ${D}${libdir}/perl/${PV}/CORE \
72 ${D}${datadir}/perl/${PV}/ExtUtils
73
74 # Save native config
75 install config.sh ${D}${libdir}/perl
76 install lib/Config.pm ${D}${libdir}/perl/${PV}/
77 install lib/ExtUtils/typemap ${D}${datadir}/perl/${PV}/ExtUtils/
78
79 # perl shared library headers
80 for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
81 uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \
82 perliol.h pp_proto.h regnodes.h unixish.h config.h EXTERN.h \
83 hv.h malloc_ctl.h pad.h perlsdio.h proto.h scope.h utf8.h \
84 cop.h fakesdio.h INTERN.h mg.h patchlevel.h perlsfio.h \
85 reentr.h sv.h utfebcdic.h cv.h fakethr.h intrpvar.h \
86 nostdio.h perlapi.h perlvars.h reentr.inc thrdvar.h util.h \
87 dosish.h form.h iperlsys.h opcode.h perl.h perly.h regcomp.h \
88 thread.h warnings.h; do
89 install $i ${D}${libdir}/perl/${PV}/CORE
90 done
91}
92do_install_append_nylon() {
93 # get rid of definitions not supported by the gcc version we use for nylon...
94 for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do
95 perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
96 done
97}
98
99PARALLEL_MAKE = ""
100
101# Perl encodes the staging path into the perl binary so we have to depend on this
102# as part of the checksum for now
103HARDPATH := "${STAGING_BINDIR}"
104do_populate_sysroot[vardeps] += "HARDPATH"