summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-native_5.24.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.24.4.bb')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.24.4.bb141
1 files changed, 0 insertions, 141 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.24.4.bb b/meta/recipes-devtools/perl/perl-native_5.24.4.bb
deleted file mode 100644
index fe44d9b8e8..0000000000
--- a/meta/recipes-devtools/perl/perl-native_5.24.4.bb
+++ /dev/null
@@ -1,141 +0,0 @@
1require perl.inc
2
3# We need gnugrep (for -I)
4DEPENDS = "db-native grep-native gdbm-native zlib-native"
5
6EXTRA_OEMAKE = "-e MAKEFLAGS="
7
8SRC_URI += "\
9 file://Configure-multilib.patch \
10 file://perl-configpm-switch.patch \
11 file://native-nopacklist.patch \
12 file://native-perlinc.patch \
13 file://MM_Unix.pm.patch \
14 file://debian/errno_ver.diff \
15 file://dynaloaderhack.patch \
16 file://perl-PathTools-don-t-filter-out-blib-from-INC.patch \
17 file://0001-Configure-Remove-fstack-protector-strong-for-native-.patch \
18 file://perl-5.26.1-guard_old_libcrypt_fix.patch \
19 file://0001-ExtUtils-MM_Unix.pm-fix-race-issues.patch \
20 file://0001-Makefile.SH-Pod-Simple-requires-Getopt-Long.patch \
21 "
22
23SRC_URI[md5sum] = "04622bc4d3941dc7eb571c52b7c02993"
24SRC_URI[sha256sum] = "7f080287ff64750270689843ae945f02159a33cb8f2fc910248c15befba5db84"
25
26inherit native
27
28NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
29
30export LD="${CCLD}"
31
32do_configure () {
33 ./Configure \
34 -Dcc="${CC}" \
35 -Dcflags="${CFLAGS}" \
36 -Dldflags="${LDFLAGS}" \
37 -Dlddlflags="${LDFLAGS} -shared" \
38 -Dcf_by="Open Embedded" \
39 -Dprefix=${prefix} \
40 -Dvendorprefix=${prefix} \
41 -Dsiteprefix=${prefix} \
42 \
43 -Dbin=${STAGING_BINDIR}/${PN} \
44 -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
45 -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
46 -Dvendorlib=${STAGING_LIBDIR}/perl/vendor_perl/${PV} \
47 -Dvendorarch=${STAGING_LIBDIR}/perl/vendor_perl/${PV} \
48 -Dsitelib=${STAGING_LIBDIR}/perl/site_perl/${PV} \
49 -Dsitearch=${STAGING_LIBDIR}/perl/site_perl/${PV} \
50 \
51 -Duseshrplib \
52 -Dusethreads \
53 -Duseithreads \
54 -Duselargefiles \
55 -Dnoextensions=ODBM_File \
56 -Ud_dosuid \
57 -Ui_db \
58 -Ui_ndbm \
59 -Ui_gdbm \
60 -Ui_gdbm_ndbm \
61 -Ui_gdbmndbm \
62 -Di_shadow \
63 -Di_syslog \
64 -Duseperlio \
65 -Dman3ext=3pm \
66 -Dsed=/bin/sed \
67 -Uafs \
68 -Ud_csh \
69 -Uusesfio \
70 -Uusenm -des
71}
72
73do_install () {
74 oe_runmake 'DESTDIR=${D}' install
75
76 # We need a hostperl link for building perl
77 ln -sf perl${PV} ${D}${bindir}/hostperl
78
79 ln -sf perl ${D}${libdir}/perl5
80
81 install -d ${D}${libdir}/perl/${PV}/CORE \
82 ${D}${datadir}/perl/${PV}/ExtUtils
83
84 # Save native config
85 install config.sh ${D}${libdir}/perl
86 install lib/Config.pm ${D}${libdir}/perl/${PV}/
87 install lib/ExtUtils/typemap ${D}${libdir}/perl/${PV}/ExtUtils/
88
89 # perl shared library headers
90 # reference perl 5.20.0-1 in debian:
91 # https://packages.debian.org/experimental/i386/perl/filelist
92 for i in av.h bitcount.h charclass_invlists.h config.h cop.h cv.h dosish.h \
93 embed.h embedvar.h EXTERN.h fakesdio.h feature.h form.h git_version.h \
94 gv.h handy.h hv_func.h hv.h inline.h INTERN.h intrpvar.h iperlsys.h \
95 keywords.h l1_char_class_tab.h malloc_ctl.h metaconfig.h mg_data.h \
96 mg.h mg_raw.h mg_vtable.h mydtrace.h nostdio.h opcode.h op.h \
97 opnames.h op_reg_common.h overload.h pad.h parser.h patchlevel.h \
98 perlapi.h perl.h perlio.h perliol.h perlsdio.h perlvars.h perly.h \
99 pp.h pp_proto.h proto.h reentr.h regcharclass.h regcomp.h regexp.h \
100 regnodes.h scope.h sv.h thread.h time64_config.h time64.h uconfig.h \
101 unicode_constants.h unixish.h utf8.h utfebcdic.h util.h uudmap.h \
102 vutil.h warnings.h XSUB.h
103 do
104 install $i ${D}${libdir}/perl/${PV}/CORE
105 done
106
107 # Those wrappers mean that perl installed from sstate (which may change
108 # path location) works and that in the nativesdk case, the SDK can be
109 # installed to a different location from the one it was built for.
110 create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/site_perl/${PV}:${STAGING_LIBDIR}/perl/vendor_perl/${PV}:${STAGING_LIBDIR}/perl/${PV}'
111 create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/site_perl/${PV}:${STAGING_LIBDIR}/perl/vendor_perl/${PV}:${STAGING_LIBDIR}/perl/${PV}'
112
113 # Use /usr/bin/env nativeperl for the perl script.
114 for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do
115 sed -i -e 's|${bindir}/perl|/usr/bin/env nativeperl|' $f
116 done
117
118 # The packlist is large with hardcoded paths meaning it needs relocating
119 # so just remove it.
120 rm ${D}${libdir}/perl/${PV}/.packlist
121}
122
123SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper"
124
125perl_sysroot_create_wrapper () {
126 mkdir -p ${SYSROOT_DESTDIR}${bindir}
127 # Create a wrapper that /usr/bin/env perl will use to get perl-native.
128 # This MUST live in the normal bindir.
129 cat > ${SYSROOT_DESTDIR}${bindir}/../nativeperl << EOF
130#!/bin/sh
131realpath=\`readlink -fn \$0\`
132exec \`dirname \$realpath\`/perl-native/perl "\$@"
133EOF
134 chmod 0755 ${SYSROOT_DESTDIR}${bindir}/../nativeperl
135 cat ${SYSROOT_DESTDIR}${bindir}/../nativeperl
136}
137
138# Fix the path in sstate
139SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"
140
141PACKAGES_DYNAMIC_class-native = "^perl-module-.*native$"