summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-native_5.20.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.20.0.bb')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.20.0.bb131
1 files changed, 131 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.20.0.bb b/meta/recipes-devtools/perl/perl-native_5.20.0.bb
new file mode 100644
index 0000000000..01d40fcff2
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-native_5.20.0.bb
@@ -0,0 +1,131 @@
1SUMMARY = "Perl scripting language"
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "libs"
4LICENSE = "Artistic-1.0 | GPL-1.0"
5
6LIC_FILES_CHKSUM = "file://Copying;md5=5b122a36d0f6dc55279a0ebc69f3c60b \
7 file://Artistic;md5=2e6fd2475335af892494fe1f7327baf3"
8
9# 5.10.1 has Module::Build built-in
10PROVIDES += "libmodule-build-perl-native"
11
12SRC_URI = "http://www.cpan.org/src/5.0/perl-${PV}.tar.gz \
13 file://Configure-multilib.patch \
14 file://perl-configpm-switch.patch \
15 file://native-nopacklist.patch \
16 file://native-perlinc.patch \
17 file://MM_Unix.pm.patch \
18 file://debian/errno_ver.diff \
19 file://dynaloaderhack.patch \
20 file://perl-5.14.3-fix-CVE-2010-4777.patch "
21
22SRC_URI[md5sum] = "406ec049ebe3afcc80d9c76ec78ca4f8"
23SRC_URI[sha256sum] = "4e8c28ad6ecc89902f9cb2e76f2815bb1a8287ded278e15f7a36ca45f8bbcd02"
24
25S = "${WORKDIR}/perl-${PV}"
26
27inherit native
28
29NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
30
31export LD="${CCLD}"
32
33do_configure () {
34 ./Configure \
35 -Dcc="${CC}" \
36 -Dcflags="${CFLAGS}" \
37 -Dldflags="${LDFLAGS}" \
38 -Dcf_by="Open Embedded" \
39 -Dprefix=${prefix} \
40 -Dvendorprefix=${prefix} \
41 -Dvendorprefix=${prefix} \
42 -Dsiteprefix=${prefix} \
43 \
44 -Dbin=${STAGING_BINDIR}/${PN} \
45 -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
46 -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
47 -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
48 -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
49 -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
50 -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
51 \
52 -Duseshrplib \
53 -Dusethreads \
54 -Duseithreads \
55 -Duselargefiles \
56 -Dnoextensions=ODBM_File \
57 -Ud_dosuid \
58 -Ui_db \
59 -Ui_ndbm \
60 -Ui_gdbm \
61 -Di_shadow \
62 -Di_syslog \
63 -Duseperlio \
64 -Dman3ext=3pm \
65 -Dsed=/bin/sed \
66 -Uafs \
67 -Ud_csh \
68 -Uusesfio \
69 -Uusenm -des
70}
71
72do_install () {
73 oe_runmake 'DESTDIR=${D}' install
74
75 # We need a hostperl link for building perl
76 ln -sf perl${PV} ${D}${bindir}/hostperl
77
78 ln -sf perl ${D}${libdir}/perl5
79
80 install -d ${D}${libdir}/perl/${PV}/CORE \
81 ${D}${datadir}/perl/${PV}/ExtUtils
82
83 # Save native config
84 install config.sh ${D}${libdir}/perl
85 install lib/Config.pm ${D}${libdir}/perl/${PV}/
86 install lib/ExtUtils/typemap ${D}${libdir}/perl/${PV}/ExtUtils/
87
88 # perl shared library headers
89 # reference perl 5.20.0-1 in debian:
90 # https://packages.debian.org/experimental/i386/perl/filelist
91 for i in av.h bitcount.h charclass_invlists.h config.h cop.h cv.h dosish.h \
92 embed.h embedvar.h EXTERN.h fakesdio.h feature.h form.h git_version.h \
93 gv.h handy.h hv_func.h hv.h inline.h INTERN.h intrpvar.h iperlsys.h \
94 keywords.h l1_char_class_tab.h malloc_ctl.h metaconfig.h mg_data.h \
95 mg.h mg_raw.h mg_vtable.h mydtrace.h nostdio.h opcode.h op.h \
96 opnames.h op_reg_common.h overload.h pad.h parser.h patchlevel.h \
97 perlapi.h perl.h perlio.h perliol.h perlsdio.h perlvars.h perly.h \
98 pp.h pp_proto.h proto.h reentr.h regcharclass.h regcomp.h regexp.h \
99 regnodes.h scope.h sv.h thread.h time64_config.h time64.h uconfig.h \
100 unicode_constants.h unixish.h utf8.h utfebcdic.h util.h uudmap.h \
101 vutil.h warnings.h XSUB.h
102 do
103 install $i ${D}${libdir}/perl/${PV}/CORE
104 done
105
106 create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl:${STAGING_LIBDIR}/perl/site_perl/${PV}:${STAGING_LIBDIR}/perl/vendor_perl/${PV}'
107 create_wrapper ${D}${bindir}/perl${PV} PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl${STAGING_LIBDIR}/perl:${STAGING_LIBDIR}/perl/site_perl/${PV}:${STAGING_LIBDIR}/perl/vendor_perl/${PV}'
108
109 # Use /usr/bin/env nativeperl for the perl script.
110 for f in `grep -Il '#! *${bindir}/perl' ${D}/${bindir}/*`; do
111 sed -i -e 's|${bindir}/perl|/usr/bin/env nativeperl|' $f
112 done
113}
114
115SYSROOT_PREPROCESS_FUNCS += "perl_sysroot_create_wrapper"
116
117perl_sysroot_create_wrapper () {
118 mkdir -p ${SYSROOT_DESTDIR}${bindir}
119 # Create a wrapper that /usr/bin/env perl will use to get perl-native.
120 # This MUST live in the normal bindir.
121 cat > ${SYSROOT_DESTDIR}${bindir}/../nativeperl << EOF
122#!/bin/sh
123realpath=\`readlink -fn \$0\`
124exec \`dirname \$realpath\`/perl-native/perl "\$@"
125EOF
126 chmod 0755 ${SYSROOT_DESTDIR}${bindir}/../nativeperl
127 cat ${SYSROOT_DESTDIR}${bindir}/../nativeperl
128}
129
130# Fix the path in sstate
131SSTATE_SCAN_FILES += "*.pm *.pod *.h *.pl *.sh"