diff options
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.12.3.bb')
-rw-r--r-- | meta/recipes-devtools/perl/perl-native_5.12.3.bb | 106 |
1 files changed, 106 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.12.3.bb b/meta/recipes-devtools/perl/perl-native_5.12.3.bb new file mode 100644 index 0000000000..0b0c9491c6 --- /dev/null +++ b/meta/recipes-devtools/perl/perl-native_5.12.3.bb | |||
@@ -0,0 +1,106 @@ | |||
1 | DESCRIPTION = "Perl is a popular scripting language." | ||
2 | HOMEPAGE = "http://www.perl.org/" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "Artistic|GPL" | ||
5 | LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \ | ||
6 | file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8" | ||
7 | PR = "r0" | ||
8 | |||
9 | LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \ | ||
10 | file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8" | ||
11 | |||
12 | SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \ | ||
13 | file://Configure-multilib.patch;patch=1 \ | ||
14 | file://perl-configpm-switch.patch;patch=1 \ | ||
15 | file://parallel_build_fix_1.patch \ | ||
16 | file://parallel_build_fix_2.patch \ | ||
17 | file://parallel_build_fix_3.patch \ | ||
18 | file://parallel_build_fix_4.patch \ | ||
19 | file://parallel_build_fix_5.patch \ | ||
20 | file://parallel_build_fix_6.patch \ | ||
21 | file://native-nopacklist.patch;patch=1 \ | ||
22 | file://native-perlinc.patch;patch=1" | ||
23 | |||
24 | SRC_URI[md5sum] = "29975a69dce54e47fcd6331c085c6c99" | ||
25 | SRC_URI[sha256sum] = "5678bfd5c2cd59253a26171bf3e681235433b00c730eea8a8046e1b225c11d2f" | ||
26 | |||
27 | S = "${WORKDIR}/perl-${PV}" | ||
28 | |||
29 | inherit native | ||
30 | |||
31 | export LD="${CCLD}" | ||
32 | |||
33 | do_configure () { | ||
34 | ./Configure \ | ||
35 | -Dcc="${CC}" \ | ||
36 | -Dcflags="${CFLAGS}" \ | ||
37 | -Dldflags="${LDFLAGS}" \ | ||
38 | -Dcf_by="Open Embedded" \ | ||
39 | -Dprefix=${prefix} \ | ||
40 | -Dvendorprefix=${prefix} \ | ||
41 | -Dvendorprefix=${prefix} \ | ||
42 | -Dsiteprefix=${prefix} \ | ||
43 | \ | ||
44 | -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \ | ||
45 | -Darchlib=${STAGING_LIBDIR}/perl/${PV} \ | ||
46 | -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \ | ||
47 | -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \ | ||
48 | -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \ | ||
49 | -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \ | ||
50 | \ | ||
51 | -Duseshrplib \ | ||
52 | -Dusethreads \ | ||
53 | -Duseithreads \ | ||
54 | -Duselargefiles \ | ||
55 | -Dnoextensions=ODBM_File \ | ||
56 | -Ud_dosuid \ | ||
57 | -Ui_db \ | ||
58 | -Ui_ndbm \ | ||
59 | -Ui_gdbm \ | ||
60 | -Di_shadow \ | ||
61 | -Di_syslog \ | ||
62 | -Duseperlio \ | ||
63 | -Dman3ext=3pm \ | ||
64 | -Uafs \ | ||
65 | -Ud_csh \ | ||
66 | -Uusesfio \ | ||
67 | -Uusenm -des | ||
68 | } | ||
69 | |||
70 | do_install () { | ||
71 | oe_runmake 'DESTDIR=${D}' install | ||
72 | |||
73 | # We need a hostperl link for building perl | ||
74 | ln -sf perl${PV} ${D}${bindir}/hostperl | ||
75 | |||
76 | ln -sf perl ${D}${libdir}/perl5 | ||
77 | |||
78 | install -d ${D}${libdir}/perl/${PV}/CORE \ | ||
79 | ${D}${datadir}/perl/${PV}/ExtUtils | ||
80 | |||
81 | # Save native config | ||
82 | install config.sh ${D}${libdir}/perl | ||
83 | install lib/Config.pm ${D}${libdir}/perl/${PV}/ | ||
84 | install lib/ExtUtils/typemap ${D}${libdir}/perl/${PV}/ExtUtils/ | ||
85 | |||
86 | # perl shared library headers | ||
87 | for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \ | ||
88 | uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \ | ||
89 | perliol.h pp_proto.h regnodes.h unixish.h config.h EXTERN.h \ | ||
90 | hv.h malloc_ctl.h pad.h perlsdio.h proto.h scope.h utf8.h \ | ||
91 | cop.h fakesdio.h INTERN.h mg.h patchlevel.h perlsfio.h \ | ||
92 | reentr.h sv.h utfebcdic.h cv.h fakethr.h intrpvar.h \ | ||
93 | nostdio.h perlapi.h perlvars.h util.h \ | ||
94 | dosish.h form.h iperlsys.h opcode.h perl.h perly.h regcomp.h \ | ||
95 | thread.h warnings.h; do | ||
96 | install $i ${D}${libdir}/perl/${PV}/CORE | ||
97 | done | ||
98 | |||
99 | create_wrapper ${D}${bindir}/perl PERL5LIB='$PERL5LIB:${STAGING_LIBDIR}/perl/${PV}:${STAGING_LIBDIR}/perl/' | ||
100 | } | ||
101 | do_install_append_nylon() { | ||
102 | # get rid of definitions not supported by the gcc version we use for nylon... | ||
103 | for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do | ||
104 | perl -pi -e 's/-Wdeclaration-after-statement //g' ${i} | ||
105 | done | ||
106 | } | ||