diff options
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.12.2.bb')
-rw-r--r-- | meta/recipes-devtools/perl/perl-native_5.12.2.bb | 104 |
1 files changed, 104 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.12.2.bb b/meta/recipes-devtools/perl/perl-native_5.12.2.bb new file mode 100644 index 0000000000..824d5076f8 --- /dev/null +++ b/meta/recipes-devtools/perl/perl-native_5.12.2.bb | |||
@@ -0,0 +1,104 @@ | |||
1 | DESCRIPTION = "Perl is a popular scripting language." | ||
2 | HOMEPAGE = "http://www.perl.org/" | ||
3 | SECTION = "libs" | ||
4 | LICENSE = "Artistic|GPL" | ||
5 | LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \ | ||
6 | file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8" | ||
7 | DEPENDS = "virtual/db-native gdbm-native" | ||
8 | PR = "r0" | ||
9 | |||
10 | LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \ | ||
11 | file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8" | ||
12 | |||
13 | SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \ | ||
14 | file://Configure-multilib.patch;patch=1 \ | ||
15 | file://perl-configpm-switch.patch;patch=1 \ | ||
16 | file://native-nopacklist.patch;patch=1 \ | ||
17 | file://native-perlinc.patch;patch=1" | ||
18 | |||
19 | SRC_URI[md5sum] = "af2df531d46b77fdf0d97eecb03eddb2" | ||
20 | SRC_URI[sha256sum] = "cf888340021d5a2d1238bbd9b8b55aaf420a848d46e4d317cb8567f86ceb1022" | ||
21 | |||
22 | S = "${WORKDIR}/perl-${PV}" | ||
23 | |||
24 | inherit native | ||
25 | |||
26 | do_configure () { | ||
27 | ./Configure \ | ||
28 | -Dcc="${CC}" \ | ||
29 | -Dcflags="${CFLAGS}" \ | ||
30 | -Dldflags="${LDFLAGS}" \ | ||
31 | -Dcf_by="Open Embedded" \ | ||
32 | -Dprefix=${prefix} \ | ||
33 | -Dvendorprefix=${prefix} \ | ||
34 | -Dvendorprefix=${prefix} \ | ||
35 | -Dsiteprefix=${prefix} \ | ||
36 | \ | ||
37 | -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \ | ||
38 | -Darchlib=${STAGING_LIBDIR}/perl/${PV} \ | ||
39 | -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \ | ||
40 | -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \ | ||
41 | -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \ | ||
42 | -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \ | ||
43 | \ | ||
44 | -Duseshrplib \ | ||
45 | -Dusethreads \ | ||
46 | -Duseithreads \ | ||
47 | -Duselargefiles \ | ||
48 | -Dnoextensions=ODBM_File \ | ||
49 | -Ud_dosuid \ | ||
50 | -Ui_db \ | ||
51 | -Ui_ndbm \ | ||
52 | -Ui_gdbm \ | ||
53 | -Di_shadow \ | ||
54 | -Di_syslog \ | ||
55 | -Duseperlio \ | ||
56 | -Dman3ext=3pm \ | ||
57 | -Uafs \ | ||
58 | -Ud_csh \ | ||
59 | -Uusesfio \ | ||
60 | -Uusenm -des | ||
61 | } | ||
62 | |||
63 | do_install () { | ||
64 | oe_runmake 'DESTDIR=${D}' install | ||
65 | |||
66 | # We need a hostperl link for building perl | ||
67 | ln -sf perl${PV} ${D}${bindir}/hostperl | ||
68 | |||
69 | ln -sf perl ${D}${libdir}/perl5 | ||
70 | |||
71 | install -d ${D}${libdir}/perl/${PV}/CORE \ | ||
72 | ${D}${datadir}/perl/${PV}/ExtUtils | ||
73 | |||
74 | # Save native config | ||
75 | install config.sh ${D}${libdir}/perl | ||
76 | install lib/Config.pm ${D}${libdir}/perl/${PV}/ | ||
77 | install lib/ExtUtils/typemap ${D}${libdir}/perl/${PV}/ExtUtils/ | ||
78 | |||
79 | # perl shared library headers | ||
80 | for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \ | ||
81 | uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \ | ||
82 | perliol.h pp_proto.h regnodes.h unixish.h config.h EXTERN.h \ | ||
83 | hv.h malloc_ctl.h pad.h perlsdio.h proto.h scope.h utf8.h \ | ||
84 | cop.h fakesdio.h INTERN.h mg.h patchlevel.h perlsfio.h \ | ||
85 | reentr.h sv.h utfebcdic.h cv.h fakethr.h intrpvar.h \ | ||
86 | nostdio.h perlapi.h perlvars.h util.h \ | ||
87 | dosish.h form.h iperlsys.h opcode.h perl.h perly.h regcomp.h \ | ||
88 | thread.h warnings.h; do | ||
89 | install $i ${D}${libdir}/perl/${PV}/CORE | ||
90 | done | ||
91 | } | ||
92 | do_install_append_nylon() { | ||
93 | # get rid of definitions not supported by the gcc version we use for nylon... | ||
94 | for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do | ||
95 | perl -pi -e 's/-Wdeclaration-after-statement //g' ${i} | ||
96 | done | ||
97 | } | ||
98 | |||
99 | PARALLEL_MAKE = "" | ||
100 | |||
101 | # Perl encodes the staging path into the perl binary so we have to depend on this | ||
102 | # as part of the checksum for now | ||
103 | HARDPATH := "${STAGING_BINDIR}" | ||
104 | do_populate_sysroot[vardeps] += "HARDPATH" | ||