summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-5.14.2/debian/fakeroot.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl-5.14.2/debian/fakeroot.diff')
-rw-r--r--meta/recipes-devtools/perl/perl-5.14.2/debian/fakeroot.diff44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-5.14.2/debian/fakeroot.diff b/meta/recipes-devtools/perl/perl-5.14.2/debian/fakeroot.diff
new file mode 100644
index 0000000000..bd90af9b39
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-5.14.2/debian/fakeroot.diff
@@ -0,0 +1,44 @@
1From a46a7107fb045ffa6047488b8002fec97b621a11 Mon Sep 17 00:00:00 2001
2From: Brendan O'Dea <bod@debian.org>
3Date: Fri, 18 Mar 2005 22:22:25 +1100
4Subject: Postpone LD_LIBRARY_PATH evaluation to the binary targets.
5
6Modify the setting of LD_LIBRARY_PATH to append pre-existing values at the
7time the rule is evaluated rather than when the Makefile is created.
8
9This is required when building packages with dpkg-buildpackage and fakeroot,
10since fakeroot (which now sets LD_LIBRARY_PATH) is not used for the "build"
11rule where the Makefile is created, but is for the clean/binary* targets.
12
13Patch-Name: debian/fakeroot.diff
14---
15 Makefile.SH | 9 ++-------
16 1 files changed, 2 insertions(+), 7 deletions(-)
17
18diff --git a/Makefile.SH b/Makefile.SH
19index eb6326a..1dac585 100755
20--- a/Makefile.SH
21+++ b/Makefile.SH
22@@ -36,12 +36,7 @@ case "$useshrplib" in
23 true)
24 # Prefix all runs of 'miniperl' and 'perl' with
25 # $ldlibpth so that ./perl finds *this* shared libperl.
26- case "$LD_LIBRARY_PATH" in
27- '')
28- ldlibpth="LD_LIBRARY_PATH=`pwd`";;
29- *)
30- ldlibpth="LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}";;
31- esac
32+ ldlibpth=LD_LIBRARY_PATH=`pwd`'$${LD_LIBRARY_PATH:+:}$$LD_LIBRARY_PATH'
33
34 pldlflags="$cccdlflags"
35 static_ldflags=''
36@@ -112,7 +107,7 @@ true)
37 ;;
38 esac
39 case "$ldlibpthname" in
40- '') ;;
41+ ''|LD_LIBRARY_PATH) ;;
42 *)
43 case "$osname" in
44 os2)