summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-5.12.2/debian/fakeroot.diff
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/perl-5.12.2/debian/fakeroot.diff')
-rw-r--r--meta/recipes-devtools/perl/perl-5.12.2/debian/fakeroot.diff43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-5.12.2/debian/fakeroot.diff b/meta/recipes-devtools/perl/perl-5.12.2/debian/fakeroot.diff
new file mode 100644
index 0000000000..e3430ce2b6
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-5.12.2/debian/fakeroot.diff
@@ -0,0 +1,43 @@
1Subject: Postpone LD_LIBRARY_PATH evaluation to the binary targets.
2
3Modify the setting of LD_LIBRARY_PATH to append pre-existing values at the
4time the rule is evaluated rather than when the Makefile is created.
5
6This is required when building packages with dpkg-buildpackage and fakeroot,
7since fakeroot (which now sets LD_LIBRARY_PATH) is not used for the "build"
8rule where the Makefile is created, but is for the clean/binary* targets.
9
10
11---
12 Makefile.SH | 9 ++-------
13 1 files changed, 2 insertions(+), 7 deletions(-)
14
15diff --git a/Makefile.SH b/Makefile.SH
16index c039938..15184d8 100755
17--- a/Makefile.SH
18+++ b/Makefile.SH
19@@ -50,12 +50,7 @@ case "$useshrplib" in
20 true)
21 # Prefix all runs of 'miniperl' and 'perl' with
22 # $ldlibpth so that ./perl finds *this* shared libperl.
23- case "$LD_LIBRARY_PATH" in
24- '')
25- ldlibpth="LD_LIBRARY_PATH=`pwd`";;
26- *)
27- ldlibpth="LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}";;
28- esac
29+ ldlibpth=LD_LIBRARY_PATH=`pwd`'$${LD_LIBRARY_PATH:+:}$$LD_LIBRARY_PATH'
30
31 pldlflags="$cccdlflags"
32 static_ldflags=''
33@@ -126,7 +121,7 @@ true)
34 ;;
35 esac
36 case "$ldlibpthname" in
37- '') ;;
38+ ''|LD_LIBRARY_PATH) ;;
39 *)
40 case "$osname" in
41 os2)
42--
43tg: (c823880..) debian/fakeroot (depends on: upstream)