summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libxml-perl_0.08.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/libxml-perl_0.08.bb')
-rw-r--r--meta/recipes-devtools/perl/libxml-perl_0.08.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libxml-perl_0.08.bb b/meta/recipes-devtools/perl/libxml-perl_0.08.bb
new file mode 100644
index 0000000000..2c01976cad
--- /dev/null
+++ b/meta/recipes-devtools/perl/libxml-perl_0.08.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "libxml-perl is a collection of smaller Perl modules, scripts, and \
2documents for working with XML in Perl. libxml-perl software \
3works in combination with XML::Parser, PerlSAX, XML::DOM, \
4XML::Grove and others."
5SUMMARY = "Collection of Perl modules for working with XML"
6SECTION = "libs"
7LICENSE = "Artistic-1.0 | GPL-1.0+"
8PR = "r3"
9
10LIC_FILES_CHKSUM = "file://README;beginline=33;endline=35;md5=1705549eef7577a3d6ba71123a1f0ce8"
11
12DEPENDS += "libxml-parser-perl"
13
14SRC_URI = "http://www.cpan.org/modules/by-module/XML/${BPN}-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "0ed5fbdda53d1301ddaed88db10503bb"
17SRC_URI[sha256sum] = "4571059b7b5d48b7ce52b01389e95d798bf5cf2020523c153ff27b498153c9cb"
18
19EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
20
21inherit cpan
22
23do_compile() {
24 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
25 cpan_do_compile
26}
27