summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libxml-perl_0.08.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/libxml-perl_0.08.bb')
-rw-r--r--meta/recipes-devtools/perl/libxml-perl_0.08.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libxml-perl_0.08.bb b/meta/recipes-devtools/perl/libxml-perl_0.08.bb
new file mode 100644
index 0000000000..04a78e34d0
--- /dev/null
+++ b/meta/recipes-devtools/perl/libxml-perl_0.08.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "libxml-perl is a collection of smaller Perl modules, scripts, and \
2documents for working with XML in Perl. libxml-perl software \
3works in combination with XML::Parser, PerlSAX, XML::DOM, \
4XML::Grove and others."
5SUMMARY = "Collection of Perl modules for working with XML."
6SECTION = "libs"
7LICENSE = "Artistic | GPLv1+"
8PR = "r0"
9
10LIC_FILES_CHKSUM = "file://README;beginline=33;endline=35;md5=1705549eef7577a3d6ba71123a1f0ce8"
11
12DEPENDS += "libxml-parser-perl"
13
14SRC_URI = "http://www.cpan.org/modules/by-module/XML/${PN}-${PV}.tar.gz"
15
16EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
17
18inherit cpan
19
20do_compile() {
21 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
22 cpan_do_compile
23}
24