summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb')
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
new file mode 100644
index 0000000000..caf5704b32
--- /dev/null
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.41.bb
@@ -0,0 +1,32 @@
1DESCRIPTION = "XML::Parser - A perl module for parsing XML documents"
2SECTION = "libs"
3LICENSE = "Artistic"
4LIC_FILES_CHKSUM = "file://README;beginline=2;endline=6;md5=c8767d7516229f07b26e42d1cf8b51f1"
5
6DEPENDS += "expat expat-native"
7
8PR = "r0"
9
10SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz"
11SRC_URI[md5sum] = "c320d2ffa459e6cdc6f9f59c1185855e"
12SRC_URI[sha256sum] = "b48197cd2265a26c5f016489f11a7b450d8833cb8b3d6a46ee15975740894de9"
13
14S = "${WORKDIR}/XML-Parser-${PV}"
15
16EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
17
18inherit cpan
19
20do_compile() {
21 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
22 cpan_do_compile
23}
24
25do_compile_virtclass-native() {
26 cpan_do_compile
27}
28
29FILES_${PN}-dbg += "${libdir}/perl/vendor_perl/*/auto/XML/Parser/Expat/.debug/"
30
31BBCLASSEXTEND="native"
32