summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb')
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb
new file mode 100644
index 0000000000..c2d1bdb8f8
--- /dev/null
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.40.bb
@@ -0,0 +1,23 @@
1SECTION = "libs"
2LICENSE = "Artistic"
3LIC_FILES_CHKSUM = "file://README;beginline=2;endline=6;md5=c8767d7516229f07b26e42d1cf8b51f1"
4DEPENDS += "expat expat-native"
5
6PR = "r0"
7
8SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "c66e9adba003d0667cc40115ccd837a5"
11SRC_URI[sha256sum] = "e5e433684e799ef7b6b852c0ca31b71054717628555444d3dc9fceac0df71512"
12
13S = "${WORKDIR}/XML-Parser-${PV}"
14
15EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
16
17inherit cpan
18
19do_compile() {
20 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
21 cpan_do_compile
22}
23