summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libxml-parser-perl_2.36.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/libxml-parser-perl_2.36.bb')
-rw-r--r--meta/recipes-devtools/perl/libxml-parser-perl_2.36.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.36.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.36.bb
new file mode 100644
index 0000000000..818840504a
--- /dev/null
+++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.36.bb
@@ -0,0 +1,21 @@
1SECTION = "libs"
2LICENSE = "Artistic"
3DEPENDS += "expat expat-native"
4
5SRC_URI = "http://www.cpan.org/modules/by-module/XML/XML-Parser-${PV}.tar.gz"
6
7S = "${WORKDIR}/XML-Parser-${PV}"
8
9EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
10
11inherit cpan
12
13do_compile() {
14 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
15 cpan_do_compile
16}
17
18
19
20FILES_${PN} = "${PERLLIBDIRS}/auto/XML/Parser/Expat/* \
21 ${PERLLIBDIRS}/XML"