summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liburi-perl_1.71.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.71.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.71.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.71.bb b/meta/recipes-devtools/perl/liburi-perl_1.71.bb
new file mode 100644
index 0000000000..a800198b33
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.71.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Perl module to manipulate and access URI strings"
2DESCRIPTION = "This package contains the URI.pm module with friends. \
3The module implements the URI class. URI objects can be used to access \
4and manipulate the various components that make up these strings."
5
6HOMEPAGE = "http://search.cpan.org/dist/URI/"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f"
11
12DEPENDS += "perl"
13
14SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "247c3da29a794f72730e01aa5a715daf"
17SRC_URI[sha256sum] = "9c8eca0d7f39e74bbc14706293e653b699238eeb1a7690cc9c136fb8c2644115"
18
19S = "${WORKDIR}/URI-${PV}"
20
21EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
22
23inherit cpan
24
25do_compile() {
26 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
27 cpan_do_compile
28}
29
30BBCLASSEXTEND = "native"