summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liburi-perl_1.59.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.59.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.59.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.59.bb b/meta/recipes-devtools/perl/liburi-perl_1.59.bb
new file mode 100644
index 0000000000..877b25212c
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.59.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "This package contains the URI.pm module with friends. \
2The module implements the URI class. URI objects can be used to access \
3and manipulate the various components that make up these strings."
4
5SECTION = "libs"
6LICENSE = "Artistic | GPLv1+"
7PR = "r0"
8
9LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=6c33ae5c87fd1c4897714e122dd9c23d"
10
11DEPENDS += "perl"
12
13SRC_URI = "http://www.cpan.org/authors/id/G/GA/GAAS/URI-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "fecebf8fa20e2d26ea4a1649c095e96e"
16SRC_URI[sha256sum] = "cb88d29b589db8d2adbc4713fd082284cba77883488717375f011bbd13b5cac6"
17
18S = "${WORKDIR}/URI-${PV}"
19
20EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
21
22inherit cpan
23
24do_compile() {
25 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
26 cpan_do_compile
27}
28