summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liberror-perl_0.17029.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/liberror-perl_0.17029.bb')
-rw-r--r--meta/recipes-devtools/perl/liberror-perl_0.17029.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liberror-perl_0.17029.bb b/meta/recipes-devtools/perl/liberror-perl_0.17029.bb
new file mode 100644
index 0000000000..038808f0cd
--- /dev/null
+++ b/meta/recipes-devtools/perl/liberror-perl_0.17029.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Error - Error/exception handling in an OO-ish way"
2DESCRIPTION = "The Error package provides two interfaces. Firstly \
3Error provides a procedural interface to exception handling. \
4Secondly Error is a base class for errors/exceptions that can \
5either be thrown, for subsequent catch, or can simply be recorded."
6HOMEPAGE = "https://github.com/shlomif/perl-error.pm"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
11
12DEPENDS += "perl"
13
14RDEPENDS_${PN} += " \
15 perl-module-carp \
16 perl-module-exporter \
17 perl-module-scalar-util \
18 perl-module-overload \
19 perl-module-strict \
20 perl-module-vars \
21 perl-module-warnings \
22"
23
24RDEPENDS_${PN}-ptest += " \
25 perl-module-base \
26 perl-module-file-spec \
27 perl-module-io-handle \
28 perl-module-ipc-open3 \
29 perl-module-lib \
30 perl-module-test-more \
31"
32
33SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
34
35SRC_URI[md5sum] = "6732b1c6207e4a9a3e2987c88368039a"
36SRC_URI[sha256sum] = "1a23f7913032aed6d4b68321373a3899ca66590f4727391a091ec19c95bf7adc"
37
38S = "${WORKDIR}/Error-${PV}"
39
40inherit cpan ptest-perl
41
42do_install_prepend() {
43 # test requires "-T" (taint) command line option
44 rm -rf ${B}/t/pod-coverage.t
45}
46
47BBCLASSEXTEND = "native"