summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liberror-perl_0.17022.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/perl/liberror-perl_0.17022.bb')
-rw-r--r--meta/recipes-devtools/perl/liberror-perl_0.17022.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liberror-perl_0.17022.bb b/meta/recipes-devtools/perl/liberror-perl_0.17022.bb
new file mode 100644
index 0000000000..071f4b7860
--- /dev/null
+++ b/meta/recipes-devtools/perl/liberror-perl_0.17022.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Error - Error/exception handling in an OO-ish way"
2DESCRIPTION = "The Error package provides two interfaces. Firstly \
3Error provides a procedural interface to exception handling. \
4Secondly Error is a base class for errors/exceptions that can \
5either be thrown, for subsequent catch, or can simply be recorded."
6
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
11
12DEPENDS += "perl"
13
14SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
15SRC_URI[md5sum] = "f4d825f4be915ae90bf2e0d66734956b"
16SRC_URI[sha256sum] = "cab74f04fb3af7088cefc2f6f96800ee52d34b82928bbb35ca51a0e5b5f9f7ef"
17
18S = "${WORKDIR}/Error-${PV}"
19
20inherit cpan
21
22do_compile() {
23 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
24 cpan_do_compile
25}
26
27BBCLASSEXTEND = "native"