summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb')
-rw-r--r--meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb b/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
new file mode 100644
index 0000000000..a032a22c22
--- /dev/null
+++ b/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Security-focused ELF files checking tool"
2DESCRIPTION = "This is a small set of various PaX aware and related \
3utilities for ELF binaries. It can check ELF binary files and running \
4processes for issues that might be relevant when using ELF binaries \
5along with PaX, such as non-PIC code or executable stack and heap."
6HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9
10SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.xz \
11"
12
13SRC_URI[md5sum] = "a580468318f0ff42edf4a8cd314cc942"
14SRC_URI[sha256sum] = "7f4a7f8db6b4743adde7582fa48992ad01776796fcde030683732f56221337d9"
15
16RDEPENDS_${PN} += "bash"
17
18export GNULIB_OVERRIDES_WINT_T = "0"
19
20do_configure_prepend() {
21 touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README
22}
23
24do_install() {
25 oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
26}
27
28BBCLASSEXTEND = "native"
29
30inherit autotools pkgconfig
31
32PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
33"
34PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap"
35PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp"
36PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
37PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools"