summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pax-utils/pax-utils_0.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/pax-utils/pax-utils_0.8.1.bb')
-rw-r--r--meta/recipes-devtools/pax-utils/pax-utils_0.8.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pax-utils/pax-utils_0.8.1.bb b/meta/recipes-devtools/pax-utils/pax-utils_0.8.1.bb
new file mode 100644
index 0000000000..1b4ee0c715
--- /dev/null
+++ b/meta/recipes-devtools/pax-utils/pax-utils_0.8.1.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Security-focused ELF files checking tool"
2DESCRIPTION = "This is a small set of various PaX aware and related \
3utilities for ELF binaries. It can check ELF binary files and running \
4processes for issues that might be relevant when using ELF binaries \
5along with PaX, such as non-PIC code or executable stack and heap."
6HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9
10SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.xz"
11
12SRC_URI[md5sum] = "bc42279c5aff3682c12be40f72805cec"
13SRC_URI[sha256sum] = "844ff25b1a11bcef92ef34b22f576f226a772b67196818656f8874513438f5b9"
14
15RDEPENDS_${PN} += "bash python"
16
17do_install() {
18 oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
19}
20
21BBCLASSEXTEND = "native"