summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb')
-rw-r--r--meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb b/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
new file mode 100644
index 0000000000..160990c142
--- /dev/null
+++ b/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
@@ -0,0 +1,59 @@
1SUMMARY = "Universally Unique Identifier (UUID) library"
2DESCRIPTION = "OSSP uuid is a ISO-C:1999 application programming interface \
3(API) and corresponding command line interface (CLI) for the generation of \
4DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant Universally Unique \
5Identifier (UUID). It supports DCE 1.1 variant UUIDs of version 1 (time \
6and node based), version 3 (name based, MD5), version 4 (random number \
7based) and version 5 (name based, SHA-1)."
8DESCRIPTION_uuid = "This package contains a tool to create Universally \
9Unique Identifiers (UUID) from the command-line."
10
11HOMEPAGE = "http://www.ossp.org/pkg/lib/uuid/"
12SECTION = "libs"
13
14LICENSE = "MIT"
15LIC_FILES_CHKSUM = "file://README;beginline=30;endline=55;md5=b394fadb039bbfca6ad9d9d769ee960e \
16 file://uuid_md5.c;beginline=1;endline=28;md5=9c1f4b2218546deae24c91be1dcf00dd"
17
18PR = "r2"
19
20SRC_URI = "http://gnome-build-stage-1.googlecode.com/files/uuid-1.6.2.tar.gz \
21 file://0001-Change-library-name.patch \
22 file://0002-uuid-preserve-m-option-status-in-v-option-handling.patch \
23 file://0003-Fix-whatis-entries.patch \
24 file://0004-fix-data-uuid-from-string.patch \
25 file://uuid-libtool.patch \
26 file://uuid-nostrip.patch \
27 file://install-pc.patch \
28 file://ldflags.patch \
29 "
30SRC_URI[md5sum] = "5db0d43a9022a6ebbbc25337ae28942f"
31SRC_URI[sha256sum] = "11a615225baa5f8bb686824423f50e4427acd3f70d394765bdff32801f0fd5b0"
32
33S = "${WORKDIR}/uuid-${PV}"
34
35inherit autotools
36
37EXTRA_OECONF = "--without-dce --without-cxx --without-perl --without-perl-compat --without-php --without-pgsql"
38EXTRA_OECONF = "--includedir=${includedir}/ossp"
39
40do_configure_prepend() {
41 # This package has a completely custom aclocal.m4, which should be acinclude.m4.
42 if [ ! -e ${S}/acinclude.m4 ]; then
43 mv ${S}/aclocal.m4 ${S}/acinclude.m4
44 fi
45
46 rm -f ${S}/libtool.m4
47}
48
49do_install_append() {
50 mkdir -p ${D}${includedir}/ossp
51 mv ${D}${libdir}/pkgconfig/uuid.pc ${D}${libdir}/pkgconfig/ossp-uuid.pc
52}
53
54PACKAGES =+ "uuid"
55FILES_uuid = "${bindir}/uuid"
56FILES_${PN} = "${libdir}/libossp-uuid.so.16*"
57FILES_${PN}-dev += "${bindir}/uuid-config"
58
59BBCLASSEXTEND = "native nativesdk"