summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb')
-rw-r--r--meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb b/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
new file mode 100644
index 0000000000..cc1ec75da1
--- /dev/null
+++ b/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb
@@ -0,0 +1,58 @@
1SUMMARY = "Universally Unique Identifier (UUID) library"
2DESCRIPTION = "OSSP uuid is a ISO-C:1999 application programming interface \
3(API) and corresponding command line interface (CLI) for the generation of \
4DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant Universally Unique \
5Identifier (UUID). It supports DCE 1.1 variant UUIDs of version 1 (time \
6and node based), version 3 (name based, MD5), version 4 (random number \
7based) and version 5 (name based, SHA-1)."
8DESCRIPTION_uuid = "This package contains a tool to create Universally \
9Unique Identifiers (UUID) from the command-line."
10
11HOMEPAGE = "http://www.ossp.org/pkg/lib/uuid/"
12SECTION = "libs"
13
14LICENSE = "ossp_uuid"
15LIC_FILES_CHKSUM = "file://README;beginline=30;endline=55;md5=b394fadb039bbfca6ad9d9d769ee960e"
16
17PR = "r0"
18
19SRC_URI = "ftp://ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz \
20 file://0001-Change-library-name.patch \
21 file://0002-uuid-preserve-m-option-status-in-v-option-handling.patch \
22 file://0003-Fix-whatis-entries.patch \
23 file://0004-fix-data-uuid-from-string.patch \
24 file://uuid-libtool.patch \
25 file://uuid-nostrip.patch \
26 "
27SRC_URI[md5sum] = "5db0d43a9022a6ebbbc25337ae28942f"
28SRC_URI[sha256sum] = "11a615225baa5f8bb686824423f50e4427acd3f70d394765bdff32801f0fd5b0"
29
30S = "${WORKDIR}/uuid-${PV}"
31
32inherit autotools
33
34EXTRA_OECONF = "--without-dce --without-cxx --without-perl --without-perl-compat --without-php --without-pgsql"
35EXTRA_OECONF = "--includedir=${includedir}/ossp"
36
37do_configure_prepend() {
38 # This package has a completely custom aclocal.m4
39 # so we need to back it up and make it usable...
40 if [ ! -e m4/ossp.m4 ]; then
41 mkdir m4
42 mv aclocal.m4 m4/ossp.m4
43 fi
44
45 rm -f libtool.m4
46}
47
48do_install_append() {
49 mkdir -p ${D}${includedir}/ossp
50 mv ${D}${libdir}/pkgconfig/uuid.pc ${D}${libdir}/pkgconfig/ossp-uuid.pc
51}
52
53PACKAGES =+ "uuid"
54FILES_uuid = "${bindir}/uuid"
55FILES_${PN} = "${libdir}/libossp-uuid.so.16*"
56FILES_${PN}-dev += "${bindir}/uuid-config"
57
58BBCLASSEXTEND = "native"