summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_svn.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_svn.bb13
1 files changed, 4 insertions, 9 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_svn.bb b/meta/recipes-devtools/opkg/opkg_svn.bb
index 76ec838875..d8af823c7c 100644
--- a/meta/recipes-devtools/opkg/opkg_svn.bb
+++ b/meta/recipes-devtools/opkg/opkg_svn.bb
@@ -16,7 +16,7 @@ SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \
16S = "${WORKDIR}/trunk" 16S = "${WORKDIR}/trunk"
17 17
18PV = "0.1.8+svnr${SRCPV}" 18PV = "0.1.8+svnr${SRCPV}"
19PR = "r1" 19PR = "r2"
20 20
21PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}" 21PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}"
22 22
@@ -29,11 +29,6 @@ do_install_append() {
29 install -d ${D}${localstatedir}/lib/opkg 29 install -d ${D}${localstatedir}/lib/opkg
30} 30}
31 31
32# Define a variable to allow distros to run configure earlier.
33# (for example, to enable loading of ethernet kernel modules before networking starts)
34OPKG_INIT_POSITION = "98"
35OPKG_INIT_POSITION_slugos = "41"
36
37pkg_postinst_${PN} () { 32pkg_postinst_${PN} () {
38#!/bin/sh 33#!/bin/sh
39if [ "x$D" != "x" ]; then 34if [ "x$D" != "x" ]; then
@@ -41,9 +36,9 @@ if [ "x$D" != "x" ]; then
41 # this happens at S98 where our good 'ole packages script used to run 36 # this happens at S98 where our good 'ole packages script used to run
42 echo "#!/bin/sh 37 echo "#!/bin/sh
43opkg-cl configure 38opkg-cl configure
44rm -f /${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure 39rm -f /${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
45" > $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure 40" > $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
46 chmod 0755 $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure 41 chmod 0755 $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
47fi 42fi
48 43
49update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100 44update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100