diff options
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.4.0.bb')
-rw-r--r-- | meta/recipes-devtools/opkg/opkg_0.4.0.bb | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.4.0.bb b/meta/recipes-devtools/opkg/opkg_0.4.0.bb new file mode 100644 index 0000000000..9b7cf3f596 --- /dev/null +++ b/meta/recipes-devtools/opkg/opkg_0.4.0.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | SUMMARY = "Open Package Manager" | ||
2 | SUMMARY_libopkg = "Open Package Manager library" | ||
3 | SECTION = "base" | ||
4 | HOMEPAGE = "http://code.google.com/p/opkg/" | ||
5 | BUGTRACKER = "http://code.google.com/p/opkg/issues/list" | ||
6 | LICENSE = "GPLv2+" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
8 | file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0" | ||
9 | |||
10 | DEPENDS = "libarchive" | ||
11 | |||
12 | PE = "1" | ||
13 | |||
14 | SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \ | ||
15 | file://opkg.conf \ | ||
16 | file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \ | ||
17 | " | ||
18 | |||
19 | SRC_URI[md5sum] = "ae51d95fee599bb4dce08453529158f5" | ||
20 | SRC_URI[sha256sum] = "f6c00515d8a2ad8f6742a8e73830315d1983ed0459cba77c4d656cfc9e7fe6fe" | ||
21 | |||
22 | inherit autotools pkgconfig systemd | ||
23 | |||
24 | target_localstatedir := "${localstatedir}" | ||
25 | OPKGLIBDIR = "${target_localstatedir}/lib" | ||
26 | |||
27 | PACKAGECONFIG ??= "libsolv" | ||
28 | |||
29 | PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg" | ||
30 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl" | ||
31 | PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl" | ||
32 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" | ||
33 | PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256" | ||
34 | PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder" | ||
35 | PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv" | ||
36 | |||
37 | EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}" | ||
38 | |||
39 | do_install_append () { | ||
40 | install -d ${D}${sysconfdir}/opkg | ||
41 | install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf | ||
42 | echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf | ||
43 | |||
44 | # We need to create the lock directory | ||
45 | install -d ${D}${OPKGLIBDIR}/opkg | ||
46 | } | ||
47 | |||
48 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive" | ||
49 | RDEPENDS_${PN}_class-native = "" | ||
50 | RDEPENDS_${PN}_class-nativesdk = "" | ||
51 | RREPLACES_${PN} = "opkg-nogpg opkg-collateral" | ||
52 | RCONFLICTS_${PN} = "opkg-collateral" | ||
53 | RPROVIDES_${PN} = "opkg-collateral" | ||
54 | |||
55 | PACKAGES =+ "libopkg" | ||
56 | |||
57 | FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/" | ||
58 | |||
59 | BBCLASSEXTEND = "native nativesdk" | ||
60 | |||
61 | CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf" | ||