summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_0.3.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.3.6.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.3.6.bb14
1 files changed, 0 insertions, 14 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.3.6.bb b/meta/recipes-devtools/opkg/opkg_0.3.6.bb
index 70f20af739..579b51166c 100644
--- a/meta/recipes-devtools/opkg/opkg_0.3.6.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.3.6.bb
@@ -12,7 +12,6 @@ DEPENDS = "libarchive"
12PE = "1" 12PE = "1"
13 13
14SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \ 14SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
15 file://opkg-configure.service \
16 file://opkg.conf \ 15 file://opkg.conf \
17 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \ 16 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
18" 17"
@@ -22,8 +21,6 @@ SRC_URI[sha256sum] = "f607f0e61be8cf8a3bbd0d2dccd9ec9e9b6c21dd4307b671c600d6eeaf
22 21
23inherit autotools pkgconfig systemd 22inherit autotools pkgconfig systemd
24 23
25SYSTEMD_SERVICE_${PN} = "opkg-configure.service"
26
27target_localstatedir := "${localstatedir}" 24target_localstatedir := "${localstatedir}"
28OPKGLIBDIR = "${target_localstatedir}/lib" 25OPKGLIBDIR = "${target_localstatedir}/lib"
29 26
@@ -46,16 +43,6 @@ do_install_append () {
46 43
47 # We need to create the lock directory 44 # We need to create the lock directory
48 install -d ${D}${OPKGLIBDIR}/opkg 45 install -d ${D}${OPKGLIBDIR}/opkg
49
50 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)};then
51 install -d ${D}${systemd_unitdir}/system
52 install -m 0644 ${WORKDIR}/opkg-configure.service ${D}${systemd_unitdir}/system/
53 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
54 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
55 -e 's,@BINDIR@,${bindir},g' \
56 -e 's,@SYSTEMD_UNITDIR@,${systemd_unitdir},g' \
57 ${D}${systemd_unitdir}/system/opkg-configure.service
58 fi
59} 46}
60 47
61RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive" 48RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
@@ -68,7 +55,6 @@ RPROVIDES_${PN} = "opkg-collateral"
68PACKAGES =+ "libopkg" 55PACKAGES =+ "libopkg"
69 56
70FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/" 57FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
71FILES_${PN} += "${systemd_unitdir}/system/"
72 58
73BBCLASSEXTEND = "native nativesdk" 59BBCLASSEXTEND = "native nativesdk"
74 60