diff options
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.3.5.bb')
-rw-r--r-- | meta/recipes-devtools/opkg/opkg_0.3.5.bb | 75 |
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.3.5.bb b/meta/recipes-devtools/opkg/opkg_0.3.5.bb new file mode 100644 index 0000000000..3e511b6bb6 --- /dev/null +++ b/meta/recipes-devtools/opkg/opkg_0.3.5.bb | |||
@@ -0,0 +1,75 @@ | |||
1 | SUMMARY = "Open Package Manager" | ||
2 | SUMMARY_libopkg = "Open Package Manager library" | ||
3 | SECTION = "base" | ||
4 | HOMEPAGE = "http://code.google.com/p/opkg/" | ||
5 | BUGTRACKER = "http://code.google.com/p/opkg/issues/list" | ||
6 | LICENSE = "GPLv2+" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
8 | file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0" | ||
9 | |||
10 | DEPENDS = "libarchive" | ||
11 | |||
12 | PE = "1" | ||
13 | |||
14 | SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \ | ||
15 | file://opkg-configure.service \ | ||
16 | file://opkg.conf \ | ||
17 | file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \ | ||
18 | " | ||
19 | |||
20 | SRC_URI[md5sum] = "d202d09ea0932943071b842626cab13c" | ||
21 | SRC_URI[sha256sum] = "734bc21dea11262113fa86b928d09812618b3966f352350cf916a6ae0d343f32" | ||
22 | |||
23 | inherit autotools pkgconfig systemd | ||
24 | |||
25 | SYSTEMD_SERVICE_${PN} = "opkg-configure.service" | ||
26 | |||
27 | target_localstatedir := "${localstatedir}" | ||
28 | OPKGLIBDIR = "${target_localstatedir}/lib" | ||
29 | |||
30 | PACKAGECONFIG ??= "libsolv" | ||
31 | |||
32 | PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg" | ||
33 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl" | ||
34 | PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl" | ||
35 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" | ||
36 | PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256" | ||
37 | PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder" | ||
38 | PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv" | ||
39 | |||
40 | EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}" | ||
41 | |||
42 | do_install_append () { | ||
43 | install -d ${D}${sysconfdir}/opkg | ||
44 | install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf | ||
45 | echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf | ||
46 | |||
47 | # We need to create the lock directory | ||
48 | install -d ${D}${OPKGLIBDIR}/opkg | ||
49 | |||
50 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)};then | ||
51 | install -d ${D}${systemd_unitdir}/system | ||
52 | install -m 0644 ${WORKDIR}/opkg-configure.service ${D}${systemd_unitdir}/system/ | ||
53 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ | ||
54 | -e 's,@SYSCONFDIR@,${sysconfdir},g' \ | ||
55 | -e 's,@BINDIR@,${bindir},g' \ | ||
56 | -e 's,@SYSTEMD_UNITDIR@,${systemd_unitdir},g' \ | ||
57 | ${D}${systemd_unitdir}/system/opkg-configure.service | ||
58 | fi | ||
59 | } | ||
60 | |||
61 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive" | ||
62 | RDEPENDS_${PN}_class-native = "" | ||
63 | RDEPENDS_${PN}_class-nativesdk = "" | ||
64 | RREPLACES_${PN} = "opkg-nogpg opkg-collateral" | ||
65 | RCONFLICTS_${PN} = "opkg-collateral" | ||
66 | RPROVIDES_${PN} = "opkg-collateral" | ||
67 | |||
68 | PACKAGES =+ "libopkg" | ||
69 | |||
70 | FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/" | ||
71 | FILES_${PN} += "${systemd_unitdir}/system/" | ||
72 | |||
73 | BBCLASSEXTEND = "native nativesdk" | ||
74 | |||
75 | CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf" | ||