summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_0.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.3.2.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.3.2.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.3.2.bb b/meta/recipes-devtools/opkg/opkg_0.3.2.bb
new file mode 100644
index 0000000000..0251b7dadc
--- /dev/null
+++ b/meta/recipes-devtools/opkg/opkg_0.3.2.bb
@@ -0,0 +1,73 @@
1SUMMARY = "Open Package Manager"
2SUMMARY_libopkg = "Open Package Manager library"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0"
9
10DEPENDS = "libarchive"
11
12PE = "1"
13
14SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
15 file://opkg-configure.service \
16 file://opkg.conf \
17 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
18"
19
20SRC_URI[md5sum] = "b2cc1baa89d0b3d49e63ab002fd2e0a6"
21SRC_URI[sha256sum] = "c9fa948a779a4e493b9669c239de317d43c43accbccbb0cf84056f9b269ba7b0"
22
23inherit autotools pkgconfig systemd
24
25SYSTEMD_SERVICE_${PN} = "opkg-configure.service"
26
27target_localstatedir := "${localstatedir}"
28OPKGLIBDIR = "${target_localstatedir}/lib"
29
30PACKAGECONFIG ??= ""
31
32PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg"
33PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
34PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
35PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
36PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
37PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder"
38PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
39
40do_install_append () {
41 install -d ${D}${sysconfdir}/opkg
42 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
43 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
44
45 # We need to create the lock directory
46 install -d ${D}${OPKGLIBDIR}/opkg
47
48 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)};then
49 install -d ${D}${systemd_unitdir}/system
50 install -m 0644 ${WORKDIR}/opkg-configure.service ${D}${systemd_unitdir}/system/
51 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
52 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
53 -e 's,@BINDIR@,${bindir},g' \
54 -e 's,@SYSTEMD_UNITDIR@,${systemd_unitdir},g' \
55 ${D}${systemd_unitdir}/system/opkg-configure.service
56 fi
57}
58
59RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config run-postinsts libarchive"
60RDEPENDS_${PN}_class-native = ""
61RDEPENDS_${PN}_class-nativesdk = ""
62RREPLACES_${PN} = "opkg-nogpg opkg-collateral"
63RCONFLICTS_${PN} = "opkg-collateral"
64RPROVIDES_${PN} = "opkg-collateral"
65
66PACKAGES =+ "libopkg"
67
68FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
69FILES_${PN} += "${systemd_unitdir}/system/"
70
71BBCLASSEXTEND = "native nativesdk"
72
73CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"