diff options
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.1.8.bb')
-rw-r--r-- | meta/recipes-devtools/opkg/opkg_0.1.8.bb | 44 |
1 files changed, 2 insertions, 42 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.1.8.bb b/meta/recipes-devtools/opkg/opkg_0.1.8.bb index 18cf0428ce..c206b3782f 100644 --- a/meta/recipes-devtools/opkg/opkg_0.1.8.bb +++ b/meta/recipes-devtools/opkg/opkg_0.1.8.bb | |||
@@ -1,48 +1,8 @@ | |||
1 | require opkg.inc | 1 | require opkg.inc |
2 | 2 | ||
3 | PROVIDES += "virtual/update-alternatives" | ||
4 | RPROVIDES_update-alternatives-cworth += "update-alternatives" | ||
5 | RCONFLICTS_update-alternatives-cworth = "update-alternatives-dpkg" | ||
6 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-config-base" | ||
7 | RDEPENDS_${PN}_virtclass-native = "" | ||
8 | RDEPENDS_${PN}_virtclass-nativesdk = "" | ||
9 | PACKAGE_ARCH_update-alternatives-cworth = "all" | ||
10 | |||
11 | SRC_URI = "http://opkg.googlecode.com/files/opkg-${PV}.tar.gz \ | 3 | SRC_URI = "http://opkg.googlecode.com/files/opkg-${PV}.tar.gz \ |
12 | file://add_vercmp.patch \ | 4 | file://add_vercmp.patch \ |
13 | file://headerfix.patch \ | 5 | file://headerfix.patch \ |
14 | " | 6 | " |
15 | |||
16 | PR = "r4" | ||
17 | |||
18 | PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}" | ||
19 | |||
20 | FILES_update-alternatives-cworth${PKGSUFFIX} = "${bindir}/update-alternatives" | ||
21 | FILES_libopkg${PKGSUFFIX}-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so" | ||
22 | FILES_libopkg${PKGSUFFIX} = "${libdir}/*.so.* ${localstatedir}/lib/opkg/" | ||
23 | |||
24 | # We need to create the lock directory | ||
25 | do_install_append() { | ||
26 | install -d ${D}${localstatedir}/lib/opkg | ||
27 | } | ||
28 | |||
29 | pkg_postinst_${PN} () { | ||
30 | #!/bin/sh | ||
31 | if [ "x$D" != "x" ]; then | ||
32 | install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d | ||
33 | # this happens at S98 where our good 'ole packages script used to run | ||
34 | echo "#!/bin/sh | ||
35 | opkg-cl configure | ||
36 | rm -f /${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure | ||
37 | " > $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure | ||
38 | chmod 0755 $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure | ||
39 | fi | ||
40 | |||
41 | update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100 | ||
42 | } | ||
43 | |||
44 | pkg_postrm_${PN} () { | ||
45 | #!/bin/sh | ||
46 | update-alternatives --remove opkg ${bindir}/opkg-cl | ||
47 | } | ||
48 | 7 | ||
8 | PR = "${INC_PR}.0" | ||