summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_0.1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.1.8.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.1.8.bb44
1 files changed, 2 insertions, 42 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.1.8.bb b/meta/recipes-devtools/opkg/opkg_0.1.8.bb
index 18cf0428ce..c206b3782f 100644
--- a/meta/recipes-devtools/opkg/opkg_0.1.8.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.1.8.bb
@@ -1,48 +1,8 @@
1require opkg.inc 1require opkg.inc
2 2
3PROVIDES += "virtual/update-alternatives"
4RPROVIDES_update-alternatives-cworth += "update-alternatives"
5RCONFLICTS_update-alternatives-cworth = "update-alternatives-dpkg"
6RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-config-base"
7RDEPENDS_${PN}_virtclass-native = ""
8RDEPENDS_${PN}_virtclass-nativesdk = ""
9PACKAGE_ARCH_update-alternatives-cworth = "all"
10
11SRC_URI = "http://opkg.googlecode.com/files/opkg-${PV}.tar.gz \ 3SRC_URI = "http://opkg.googlecode.com/files/opkg-${PV}.tar.gz \
12 file://add_vercmp.patch \ 4 file://add_vercmp.patch \
13 file://headerfix.patch \ 5 file://headerfix.patch \
14" 6 "
15
16PR = "r4"
17
18PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}"
19
20FILES_update-alternatives-cworth${PKGSUFFIX} = "${bindir}/update-alternatives"
21FILES_libopkg${PKGSUFFIX}-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
22FILES_libopkg${PKGSUFFIX} = "${libdir}/*.so.* ${localstatedir}/lib/opkg/"
23
24# We need to create the lock directory
25do_install_append() {
26 install -d ${D}${localstatedir}/lib/opkg
27}
28
29pkg_postinst_${PN} () {
30#!/bin/sh
31if [ "x$D" != "x" ]; then
32 install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
33 # this happens at S98 where our good 'ole packages script used to run
34 echo "#!/bin/sh
35opkg-cl configure
36rm -f /${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
37" > $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
38 chmod 0755 $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure
39fi
40
41update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
42}
43
44pkg_postrm_${PN} () {
45#!/bin/sh
46update-alternatives --remove opkg ${bindir}/opkg-cl
47}
48 7
8PR = "${INC_PR}.0"